aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 12:11:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:28:59 +0200
commitcad75541a2da9f620f437766cbef951828331c93 (patch)
treefa90da7319bab7eeda07c582798bd8d9eb62f847
parent7704b3f5fdfe2d30013b28bc35f8768b325877c6 (diff)
downloadguix-cad75541a2da9f620f437766cbef951828331c93.tar.gz
guix-cad75541a2da9f620f437766cbef951828331c93.zip
gnu: Add texlive-ebgaramond.
* gnu/packages/tex.scm (texlive-ebgaramond): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 0972cb5ce7..e05186c16c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10627,6 +10627,33 @@ Gaulle (now deceased), under a free licence. It replaces the old full
to the PGF mathematical engine.")
(license license:lppl1.3+)))
+(define-public texlive-ebgaramond
+ (package
+ (name "texlive-ebgaramond")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/ebgaramond/"
+ "fonts/enc/dvips/ebgaramond/"
+ "fonts/map/dvips/ebgaramond/"
+ "fonts/opentype/public/ebgaramond/"
+ "fonts/tfm/public/ebgaramond/"
+ "fonts/type1/public/ebgaramond/"
+ "fonts/vf/public/ebgaramond/"
+ "tex/latex/ebgaramond/")
+ (base32
+ "1pa3zrlp9pr31mqir22nfz3rpvv63qnc85xi1bc8vw71pgfymdws")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/ebgaramond")
+ (synopsis "LaTeX support for EBGaramond fonts")
+ (description
+ "EB Garamond is a revival by Georg Duffner of the 16th century fonts
+designed by Claude Garamond. The LaTeX support package works for (pdf)LaTeX,
+XeLaTeX and LuaLaTeX users; configuration files for use with @code{microtype}
+are provided.")
+ (license (list license:silofl1.1 license:lppl))))
+
(define-public texlive-ecltree
(package
(name "texlive-ecltree")