aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-15 23:52:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:27 +0200
commitca177406f77c02ce6d0424384c9cbc399e9e1b57 (patch)
tree38d38b572d0da6b2f775e25260a25aa368ca2f2c
parent409d963ab93350c2831a62ef26b73a6c821a829e (diff)
downloadguix-ca177406f77c02ce6d0424384c9cbc399e9e1b57.tar.gz
guix-ca177406f77c02ce6d0424384c9cbc399e9e1b57.zip
gnu: Add texlive-checklistings.
* gnu/packages/tex.scm (texlive-checklistings): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d10defafa6..109a2ae1ab 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1295,6 +1295,33 @@ document, together with the document itself, using the @code{filecontents*}
environment.")
(license license:lppl1.3c)))
+(define-public texlive-checklistings
+ (package
+ (name "texlive-checklistings")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/checklistings/"
+ "scripts/checklistings/"
+ "source/latex/checklistings/"
+ "tex/latex/checklistings/")
+ (base32
+ "1ggq4i7nfx6ijqikgr48qgaaf7rd9h4a834gwsz8dv5f0zmgg1za")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "checklistings.sh")))
+ (home-page "https://ctan.org/pkg/checklistings")
+ (synopsis
+ "Pass verbatim contents through a compiler and reincorporate the resulting output")
+ (description
+ "This package augments the @code{fancyvrb} and @code{listings} packages
+to allow the source code they contain to be checked by an external tool (like
+a compiler). The external tool's messages can be automatically reincorporated
+into the original document. The package does not focus on a specific
+programming language, but it is designed to work well with languages and
+compilers in the ML family.")
+ (license license:lppl1.2+)))
+
(define-public texlive-dvipsconfig
(package
(name "texlive-dvipsconfig")