aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-17 12:39:25 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:25 +0000
commitca15f2c3affbe2a798752cd0914dc399c5f1f9fc (patch)
treead4185ffc6739841298c0894383bc4a1254a6868
parent9b8cbb544d4a92b949337ae4d26ec3f22dda6237 (diff)
downloadguix-ca15f2c3affbe2a798752cd0914dc399c5f1f9fc.tar.gz
guix-ca15f2c3affbe2a798752cd0914dc399c5f1f9fc.zip
gnu: python-xlsxwriter: Update to 3.2.0.
* gnu/packages/python-xyz.scm (python-xlsxwriter): Update to 3.2.0. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I1083b2690477070fccb203a6c0e7af2ab52eef5c
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b0ea1b4cfc..f976704382 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11394,7 +11394,7 @@ a front-end for C compilers or analysis tools.")
(define-public python-xlsxwriter
(package
(name "python-xlsxwriter")
- (version "3.0.3")
+ (version "3.2.0")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -11404,8 +11404,11 @@ a front-end for C compilers or analysis tools.")
(commit (string-append "RELEASE_" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1lr7mmik6r4zns069i4zfx1cnwhz6snmlh2zsiry0cwx8cv33wpm"))))
- (build-system python-build-system)
+ (base32 "1g16xb4nsjd807qcm8756ixlxxvdjmbr2v7r6wxkajw1h4m8id0w"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
(home-page "https://github.com/jmcnamara/XlsxWriter")
(synopsis "Python module for creating Excel XLSX files")
(description