aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRutherther <rutherther@protonmail.com>2024-09-13 11:42:19 +0000
committerLudovic Courtès <ludo@gnu.org>2024-10-12 19:23:34 +0200
commitc9aae9300af62686179009302d5b02e8c11b98b7 (patch)
tree1b789915b688b487067c579db975951e57122f4e
parent9dabdd9e508aba06431a7aef068255f818fb38ad (diff)
downloadguix-c9aae9300af62686179009302d5b02e8c11b98b7.tar.gz
guix-c9aae9300af62686179009302d5b02e8c11b98b7.zip
gnu: newlib arm-none-eabi-7-2018-q2-update: Add proper newlib-nano variant.
The nano variant for was not nano. It was just a copy of the original one with different name. This meant there were no _nano.a files present at all, and the flags were the same, not producing a smaller library. * gnu/packages/embedded.scm (make-base-newlib-arm-none-eabi-7-2018-q2-update): Rename variable from make-newlib-arm-none-eabi-7-2018-q2-update. * gnu/packages/embedded.scm (make-newlib-nano-arm-none-eabi-7-2018-q2-update): Add variable. * gnu/packages/embedded.scm (make-newlib-arm-none-eabi-7-2018-q2-update): Inherit from make-base-newlib-arm-none-eabi-7-2018-q2-update. Change-Id: I01517ed860dfb2b6a9c7e912fd724832f5a0500a Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/embedded.scm26
1 files changed, 10 insertions, 16 deletions
diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index 847eb8059c..4b9da1f529 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -247,10 +247,7 @@ embedded-4_9-branch/")
(modify-phases %standard-phases
(add-after 'unpack 'fix-references-to-/bin/sh
(lambda _
- (substitute* '("libgloss/arm/cpu-init/Makefile.in"
- "libgloss/arm/Makefile.in"
- "libgloss/libnosys/Makefile.in"
- "libgloss/Makefile.in")
+ (substitute* (find-files "libgloss" "^Makefile\\.in$")
(("/bin/sh") (which "sh")))
#t)))))
(native-inputs
@@ -430,12 +427,11 @@ embedded-7-branch/")
(variable "CROSS_LIBRARY_PATH")
(files '("arm-none-eabi/lib")))))))))
-(define make-newlib-arm-none-eabi-7-2018-q2-update
+(define make-base-newlib-arm-none-eabi-7-2018-q2-update
;; This is the same commit as used for the 7-2018-q2-update release
;; according to the release.txt.
- (mlambda ()
- (let ((base (make-newlib-arm-none-eabi))
- (commit "3ccfb407af410ba7e54ea0da11ae1e40b554a6f4")
+ (mlambda (base)
+ (let ((commit "3ccfb407af410ba7e54ea0da11ae1e40b554a6f4")
(revision "0"))
(package
(inherit base)
@@ -464,15 +460,13 @@ embedded-7-branch/")
("xgcc" ,(make-gcc-arm-none-eabi-7-2018-q2-update))
("texinfo" ,texinfo)))))))
-(define-public make-newlib-nano-arm-none-eabi-7-2018-q2-update
+(define make-newlib-arm-none-eabi-7-2018-q2-update
(mlambda ()
- (let ((base (make-newlib-arm-none-eabi-7-2018-q2-update)))
- (package
- (inherit base)
- (name "newlib-nano")
- (arguments
- (package-arguments base))
- (synopsis "Newlib variant for small systems with limited memory")))))
+ (make-base-newlib-arm-none-eabi-7-2018-q2-update (make-newlib-arm-none-eabi))))
+
+(define make-newlib-nano-arm-none-eabi-7-2018-q2-update
+ (mlambda ()
+ (make-base-newlib-arm-none-eabi-7-2018-q2-update (make-newlib-nano-arm-none-eabi))))
(define make-libstdc++-arm-none-eabi