aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 21:38:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commitc94fc0596f722aa46916983170e41dd0e1c78713 (patch)
tree20fb0e3cb318df954ecfaf807da643e207e43290
parenta704c8a005240846c37c8dd49f00a46f0347c592 (diff)
downloadguix-c94fc0596f722aa46916983170e41dd0e1c78713.tar.gz
guix-c94fc0596f722aa46916983170e41dd0e1c78713.zip
gnu: go-filippo-io-age: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-filippo-io-age): Move from here ... * gnu/packages/golang-crypto.scm: ... to here. Change-Id: I4eeadfd946910d56d2441a3469967d681b9e8677
-rw-r--r--gnu/packages/golang-crypto.scm32
-rw-r--r--gnu/packages/golang.scm29
2 files changed, 31 insertions, 30 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 9c9e3d26b8..7dede78874 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -11,11 +11,12 @@
;;; Copyright © 2021 Vagrant Cascadian <vagrant@debian.org>
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2022, 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
-;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2023 Jack Hill <jackhill@jackhill.us>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -53,6 +54,35 @@
;;;
;;; Code:
+(define-public go-filippo-io-age
+ (package
+ (name "go-filippo-io-age")
+ (version "1.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/FiloSottile/age")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1k1dv1jkr72qpk5g363mhrg9hnf5c9qgv4l16l13m4yh08jp271d"))))
+ (build-system go-build-system)
+ (arguments `(#:import-path "filippo.io/age"))
+ (inputs
+ (list go-golang-org-x-sys
+ go-golang-org-x-term
+ go-golang-org-x-crypto
+ go-filippo-io-edwards25519))
+ (home-page "https://filippo.io/age")
+ (synopsis "Secure file encryption tool, format, and Go library")
+ (description
+ "This package implements file encryption according to the
+@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
+It features small explicit keys, no configuration options, and Unix-style
+composability.")
+ (license license:bsd-3)))
+
(define-public go-filippo-io-edwards25519
(package
(name "go-filippo-io-edwards25519")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 885609b17e..149b99fbb1 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9397,35 +9397,6 @@ configuration languages, but other uses may be possible too.")
(description "This package implements a low-level key/value store in Go.")
(license license:expat)))
-(define-public go-filippo-io-age
- (package
- (name "go-filippo-io-age")
- (version "1.1.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/FiloSottile/age")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1k1dv1jkr72qpk5g363mhrg9hnf5c9qgv4l16l13m4yh08jp271d"))))
- (build-system go-build-system)
- (arguments `(#:import-path "filippo.io/age"))
- (inputs
- (list go-golang-org-x-sys
- go-golang-org-x-term
- go-golang-org-x-crypto
- go-filippo-io-edwards25519))
- (home-page "https://filippo.io/age")
- (synopsis "Secure file encryption tool, format, and Go library")
- (description
- "This package implements file encryption according to the
-@{age-encryption.org/v1, https://age-encryption.org/v1} specification.
-It features small explicit keys, no configuration options, and Unix-style
-composability.")
- (license license:bsd-3)))
-
(define-public age
(package
(inherit go-filippo-io-age)