aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-04-01 14:56:47 -0500
committerEric Bavier <bavier@member.fsf.org>2015-04-02 10:40:35 -0500
commitc90361b32265b9332d7633e3df5b944486ae63a3 (patch)
treeaa0795a16b5a30193876960ab6188e857289cede
parente210472d9fb9fd640d250dab3854a228f193c372 (diff)
downloadguix-c90361b32265b9332d7633e3df5b944486ae63a3.tar.gz
guix-c90361b32265b9332d7633e3df5b944486ae63a3.zip
gnu: Add DateTime.
* gnu/packages/perl.scm (perl-datetime): New variable.
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6cb710e921..a4df03196b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1043,6 +1043,34 @@ support for per-object behavior, circular structures, visiting tied
structures, and all ref types (hashes, arrays, scalars, code, globs).")
(license (package-license perl))))
+(define-public perl-datetime
+ (package
+ (name "perl-datetime")
+ (version "1.18")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+ "DateTime-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0fli1ls298qa8nfki15myxqqqfpxvslxk4j5r3vjk577wfgjrnms"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-fatal" ,perl-test-fatal)
+ ("perl-test-warnings" ,perl-test-warnings)))
+ (propagated-inputs
+ `(("perl-datetime-locale" ,perl-datetime-locale)
+ ("perl-datetime-timezone" ,perl-datetime-timezone)
+ ("perl-params-validate" ,perl-params-validate)
+ ("perl-try-tiny" ,perl-try-tiny)))
+ (home-page "http://search.cpan.org/dist/DateTime")
+ (synopsis "Date and time object for Perl")
+ (description "DateTime is a class for the representation of date/time
+combinations. It represents the Gregorian calendar, extended backwards in
+time before its creation (in 1582).")
+ (license artistic2.0)))
+
(define-public perl-datetime-locale
(package
(name "perl-datetime-locale")