aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-11-29 09:29:58 +0900
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 21:01:38 +0000
commitc7a5b9a11edaefd114304f23d729aba1309ceb55 (patch)
tree08d55baa2b83bf16273205848cb2838bd2261aae
parent0287db4bcb47725d6c53e5957a073d56c50873ff (diff)
downloadguix-c7a5b9a11edaefd114304f23d729aba1309ceb55.tar.gz
guix-c7a5b9a11edaefd114304f23d729aba1309ceb55.zip
gnu: Remove python-filelock-3.5.
* gnu/packages/bioinformatics.scm (python-filelock-3.5): Delete variable. (python-genomepy) [propagated-inputs]: Replace python-filelock-3.5 with python-filelock. Change-Id: I74b58c5143dc3f633e44cc9b92307520b160f43f
-rw-r--r--gnu/packages/bioinformatics.scm4
-rw-r--r--gnu/packages/python-xyz.scm21
2 files changed, 1 insertions, 24 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 1e9fdd404a..6c2cb730fb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8082,9 +8082,7 @@ high-throughput sequencing (HTS) assays")
python-click
python-colorama
python-diskcache
- ;; We cannot use an older filelock, because the
- ;; @lock annotation is used here.
- python-filelock-3.5
+ python-filelock
python-loguru
python-mygene
python-mysql-connector-python
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4ee54b78aa..99af1e8a6b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3552,27 +3552,6 @@ a platform independent file lock in Python, which provides a simple way of
inter-process communication.")
(license license:unlicense)))
-(define-public python-filelock-3.5
- (package
- (name "python-filelock")
- (version "3.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "filelock" version))
- (sha256
- (base32
- "058av1r760ws7z6qffsjpqa39fmdxw0s1wnyr7p50y3zclg6cyqk"))))
- (build-system pyproject-build-system)
- (native-inputs (list python-pytest python-setuptools-scm
- python-setuptools python-wheel))
- (home-page "https://github.com/tox-dev/filelock")
- (synopsis "Platform independent file lock")
- (description "@code{filelock} contains a single module implementing
-a platform independent file lock in Python, which provides a simple way of
-inter-process communication.")
- (license license:unlicense)))
-
(define-public python-semantic-version
(package
(name "python-semantic-version")