aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-01 23:47:14 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-01 23:48:28 -0400
commitc6d94920090da1d4a5533bfa6c4f86baec1e078c (patch)
treef7778d1ded324e7266bb0f350c9a08f0b0b7aee1
parent314b436fe6705189e7be148d262b1c0d636a9c45 (diff)
downloadguix-c6d94920090da1d4a5533bfa6c4f86baec1e078c.tar.gz
guix-c6d94920090da1d4a5533bfa6c4f86baec1e078c.zip
gnu: Add python-autoflake8.
* gnu/packages/python-xyz.scm (python-autoflake8): New variable.
-rw-r--r--gnu/packages/python-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c2f9d7b73..42a1270562 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10855,6 +10855,32 @@ file (e.g. @file{PKG-INFO}).")
cyclomatic complexity of Python source code.")
(license license:expat)))
+(define-public python-autoflake8
+ (package
+ (name "python-autoflake8")
+ (version "0.4.0")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/fsouza/autoflake8")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jx7bkslbhr24yvq60pl39faz2r6g93f1zm1gygswl0rzr5zmgnh"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-aiofiles
+ python-poetry-core
+ python-pytest
+ python-pytest-xdist))
+ (propagated-inputs (list python-pyflakes))
+ (home-page "https://github.com/fsouza/autoflake8")
+ (synopsis "Automatically fix issues reported by flake8")
+ (description "Tool to automatically fix some issues reported by
+@command{flake8}.")
+ (license license:expat)))
+
(define-public python-flake8
(package
(name "python-flake8")