aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-19 16:31:20 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:40 +0200
commitc6d117f867800b4f12dbc9944ee9732b7cbdd0ba (patch)
treed4910e0a7499d4b17e47ba82b3a62493b68104ed
parentdc87a11f9ec37992d27d1fdc2313e2d39e2c9fb0 (diff)
downloadguix-c6d117f867800b4f12dbc9944ee9732b7cbdd0ba.tar.gz
guix-c6d117f867800b4f12dbc9944ee9732b7cbdd0ba.zip
gnu: texlive-knuth-lib: Fix build.
* gnu/packages/tex.scm (texlive-knuth-lib)[arguments]<#:modules>: Remove them. <#:phases>: Remove them.
-rw-r--r--gnu/packages/tex.scm58
1 files changed, 1 insertions, 57 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index b34ad62711..d88b98e38e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1446,63 +1446,7 @@ conversion software and word processors.")
(base32
"0dl8z340n6m6xn7wari4hir0syxqi0kl2fhnf0bvnmkqhqwyzpca")))
(build-system texlive-build-system)
- (arguments
- (list
- #:texlive-latex-base #f
- #:modules
- '((guix build texlive-build-system)
- (guix build utils)
- (srfi srfi-1)
- (srfi srfi-26))
- #:phases
- #~(modify-phases %standard-phases
- (add-before 'install 'generate-fonts-metrics
- (lambda _
- (let ((cm #$(this-package-native-input "texlive-cm"))
- (metafont #$(this-package-native-input "texlive-metafont"))
- (fonts-directories
- (delete-duplicates
- (map (lambda (f)
- (string-drop (dirname f) (string-length "./")))
- (find-files "." "[0-9]+\\.mf$"))))
- (root (getcwd)))
- (mkdir-p "build")
- ;; Tell mf where to find mf.base.
- (setenv "MFBASES"
- (string-append metafont "/share/texmf-dist/web2c/"))
- (for-each
- (lambda (directory)
- ;; Tell mf where to look for source files.
- (setenv "MFINPUTS"
- (string-append
- (getcwd) "/" directory ":"
- metafont "/share/texmf-dist/metafont/base/:"
- cm "/share/texmf-dist/fonts/source/public/cm/"))
- ;; Build font metrics (tfm).
- (with-directory-excursion directory
- (for-each (lambda (font)
- (format #t "building font ~a\n" font)
- (invoke "mf" "-progname=mf"
- (string-append "-output-directory="
- root "/build")
- (string-append "\\"
- "mode:=ljfour; "
- "mag:=1; "
- "batchmode; "
- "input "
- (basename font ".mf"))))
- (find-files "." "[0-9]+\\.mf$")))
- ;; Install font metrics at the appropriate location.
- (let ((destination
- ;; fonts/source/xxx/yyy/... -> fonts/tfm/xxx/yyy/...
- (string-append "fonts/tfm"
- (string-drop
- directory
- (string-length "fonts/source")))))
- (format #t "moving font metrics in ~a\n" destination)
- (for-each (cut install-file <> destination)
- (find-files "build/" "\\.tfm$"))))
- fonts-directories)))))))
+ (arguments (list #:texlive-latex-base #f))
(native-inputs (list texlive-cm texlive-metafont))
(home-page "https://ctan.org/pkg/knuth-lib")
(synopsis "Small library of METAFONT sources")