aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:21 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:50 +0000
commitc5de62092a4252ca106cb3c829a11ef36aa45a3f (patch)
tree559d9f49400b727d5f32bf130e7e74271fe8f809
parentadcada92da1ac81a95d5f4155915cd791f49703a (diff)
downloadguix-c5de62092a4252ca106cb3c829a11ef36aa45a3f.tar.gz
guix-c5de62092a4252ca106cb3c829a11ef36aa45a3f.zip
gnu: python-arrow: Move to pyproject-build-system.
* gnu/packages/time.scm (python-arrow): Improve package style. [build-system]: Move to pyproject-build-system. [arguments]: Moving check replacement phase from <#:phases> to equivalent <#:test-flags>. Change-Id: I7e3d356610d624855c3898ccdbfb308ce9f6e627 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/time.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index c2d45239ea..4d4b746226 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -512,17 +512,13 @@ timestamps.")
(sha256
(base32
"189knrgxb3x21lzvqac6qlpd32308hcmpccxdlvr5wmrl46b6d1r"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "tests"
- ;; python-dateutil doesn't recognize America/Nuuk.
- ;; Remove when python-dateutil > 2.8.1.
- "-k" "not test_parse_tz_name_zzz")))))))
+ (list
+ #:test-flags '(list "tests"
+ ;; python-dateutil doesn't recognize America/Nuuk.
+ ;; Remove when python-dateutil > 2.8.1.
+ "-k" "not test_parse_tz_name_zzz")))
(native-inputs
(list ;; For testing
python-chai