aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:12:36 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 15:45:55 +0200
commitc55e42d3e3a21687b373daa9998317db13ee419a (patch)
treea9bb87211de0dceab8fda141f530f9ce4c5b289e
parentb2bec5be7e1947a9dbf6c7bc2b3d40ac30455080 (diff)
downloadguix-c55e42d3e3a21687b373daa9998317db13ee419a.tar.gz
guix-c55e42d3e3a21687b373daa9998317db13ee419a.zip
gnu: Add texlive-maze.
* gnu/packages/tex.scm (texlive-maze): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 50aba837a4..a57209d7dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10081,6 +10081,25 @@ representation of common vectors and tensors such as forces, velocities,
moments of inertia, etc.")
(license license:lppl1.3c)))
+(define-public texlive-maze
+ (package
+ (name "texlive-maze")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/maze/" "tex/latex/maze/")
+ (base32
+ "0dwsv62rpyll1cfh1qpz6msmypc1a61b1pb0a7lm89ks1cj42zmg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/maze")
+ (synopsis "Generate random mazes")
+ (description
+ "This package can generate random square mazes of a specified size.
+The mazes generated by this package are natural and their solution is not too
+obvious. The output it based on the @code{picture} environment.")
+ (license license:lppl1.3c)))
+
(define-public texlive-mecaso
(package
(name "texlive-mecaso")