aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 16:01:50 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:06:24 +0200
commitc51b8c123adab28529ca6935f862f4e9f990db0c (patch)
tree76f46867a19d21b0afeb2f1dbf5473c1531a756f
parentf724881df01996eb8de4b0e5f37d3bdd11f21acb (diff)
downloadguix-c51b8c123adab28529ca6935f862f4e9f990db0c.tar.gz
guix-c51b8c123adab28529ca6935f862f4e9f990db0c.zip
gnu: Add texlive-stack.
* gnu/packages/tex.scm (texlive-stack): New variable.
-rw-r--r--gnu/packages/tex.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4825eabe0f..691b9a5831 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -96415,6 +96415,25 @@ available.")
user may add headers and footers to the slide.")
(license license:lppl1.3+)))
+(define-public texlive-stack
+ (package
+ (name "texlive-stack")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "source/latex/stack/" "tex/latex/stack/")
+ (base32
+ "0annz6qz921m1f7l2scqsg9kh10xxihizwf0gg10drm6yvxmy7ha")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/stack")
+ (synopsis "Tools to define and use stacks")
+ (description
+ "The package provides a small set of commands to implement stacks
+independently of TeX's own stack. As an example of how the stacks might be
+used, the documentation offers a small @code{relinput} package that implements
+the backbone of the @code{import} package.")
+ (license license:lppl)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar