aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-02 00:19:53 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-02 00:19:53 +0200
commitc2366e3ce4596382df6811661abd8612ecabb23d (patch)
tree6a6409f0e79a054c5735dede65ded3c3c3da5505
parent112da5887550ab929112dbe4ce9df535fc0a7006 (diff)
downloadguix-c2366e3ce4596382df6811661abd8612ecabb23d.tar.gz
guix-c2366e3ce4596382df6811661abd8612ecabb23d.zip
gnu: commencement: Turn off RUNPATH checks for 'gcc-final'.
* gnu/packages/commencement.scm (gcc-final)[arguments]: Add #:validate-runpath? #f.
-rw-r--r--gnu/packages/commencement.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index d96a8237c3..b421ab08ef 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -500,6 +500,11 @@ exec ~a/bin/~a-~a -B~a/lib -Wl,-dynamic-linker -Wl,~a/~a \"$@\"~%"
#:allowed-references ("out" "lib" ,glibc-final)
+ ;; Things like libasan.so and libstdc++.so NEED ld.so and/or
+ ;; libgcc_s.so but RUNPATH is empty. This is a false positive, so turn
+ ;; it off.
+ #:validate-runpath? #f
+
;; Build again GMP & co. within GCC's build process, because it's hard
;; to do outside (because GCC-BOOT0 is a cross-compiler, and thus
;; doesn't honor $LIBRARY_PATH, which breaks `gnu-build-system'.)