aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 15:22:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:37 +0100
commitc20a81eed1b22b4cec136f78925bcc4d2be2393f (patch)
treee45ea1cee207c9d342eb63f221e5c94a9d7a7038
parent303c7d1dff7e0a2f91591489c83fb0dfa15ca8a8 (diff)
downloadguix-c20a81eed1b22b4cec136f78925bcc4d2be2393f.tar.gz
guix-c20a81eed1b22b4cec136f78925bcc4d2be2393f.zip
gnu: Add r-fastmap.
* gnu/packages/cran.scm (r-fastmap): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3b7cb48038..de66afcabc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -729,6 +729,30 @@ objects in HTML format.")
and vice-versa.")
(license license:gpl2+)))
+(define-public r-fastmap
+ (package
+ (name "r-fastmap")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastmap" version))
+ (sha256
+ (base32
+ "1v7sp56xiha0bh78g3w92k52p9vkp7ryzpw0z66nyddxzrfv0y27"))))
+ (properties `((upstream-name . "fastmap")))
+ (build-system r-build-system)
+ (home-page "https://r-lib.github.io/fastmap/")
+ (synopsis "Fast implementation of a key-value store")
+ (description
+ "This package provides a fast implementation of a key-value store.
+Environments are commonly used as key-value stores, but every time a new key
+is used, it is added to R's global symbol table, causing a small amount of
+memory leakage. This can be problematic in cases where many different keys
+are used. Fastmap avoids this memory leak issue by implementing the map using
+data structures in C++.")
+ (license license:expat)))
+
(define-public r-shiny
(package
(name "r-shiny")