aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain GARBAGE <romain.garbage@inria.fr>2024-07-22 13:28:01 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-07-23 00:31:19 +0200
commitc13609005eeaa6502d868f4cdb3e51e49eda4577 (patch)
treeee3fcc5583df3b58523f5e82f29efc924f1f8b9c
parent9539293213a5de9070d43ea038b82a540941d186 (diff)
downloadguix-c13609005eeaa6502d868f4cdb3e51e49eda4577.tar.gz
guix-c13609005eeaa6502d868f4cdb3e51e49eda4577.zip
gnu: Add ghc-crypton-x509-system.
* gnu/packages/haskell-crypto.scm (ghc-crypton-x509-system): New variable. Change-Id: Idfadaf630a3bcc4d019738d37ae9ee888f49fd80
-rw-r--r--gnu/packages/haskell-crypto.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell-crypto.scm b/gnu/packages/haskell-crypto.scm
index 7b06676024..ce59f0a23c 100644
--- a/gnu/packages/haskell-crypto.scm
+++ b/gnu/packages/haskell-crypto.scm
@@ -702,6 +702,26 @@ collections of certificates, certificate revocation lists, and exception
lists.")
(license license:bsd-3)))
+(define-public ghc-crypton-x509-system
+ (package
+ (name "ghc-crypton-x509-system")
+ (version "1.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "crypton-x509-system" version))
+ (sha256
+ (base32 "1jilnr9715njlx1hqvg5lrsrwk12r04maypmh18di0sybwg2cdm4"))))
+ (build-system haskell-build-system)
+ (properties '((upstream-name . "crypton-x509-system")))
+ (inputs (list ghc-pem ghc-crypton-x509 ghc-crypton-x509-store))
+ (home-page "https://github.com/kazu-yamamoto/crypton-certificate")
+ (synopsis "Handle per-operating-system X.509 accessors and storage")
+ (description
+ "This package provides tools for operating system dependent X.509 stores,
+storage methods, and accessors.")
+ (license license:bsd-3)))
+
(define-public ghc-cprng-aes
(package
(name "ghc-cprng-aes")