aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-17 12:29:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:31 +0300
commitbe2135fb6afa6bef261bdd37a30de66a4c0e68e7 (patch)
treea5283bc04844a1dc6be9ba1055dc0f86a5a8195e
parent03139fe8a5db5325689fc6debcd82b4726edf047 (diff)
downloadguix-be2135fb6afa6bef261bdd37a30de66a4c0e68e7.tar.gz
guix-be2135fb6afa6bef261bdd37a30de66a4c0e68e7.zip
gnu: Add rust-fragile-2.
* gnu/packages/crates-io.scm (rust-fragile-2): New variable. (rust-fragile-1): Inherit from rust-fragile-2. Change-Id: I9ebdd331f2890d02b7af0e19edd9797f098e6bce
-rw-r--r--gnu/packages/crates-io.scm25
1 files changed, 20 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 11828f7129..1f7254e826 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -25683,25 +25683,40 @@ the controling terminal (daemon) using the fork and setsid syscalls.")
syntax, as used by HTML forms.")
(license (list license:expat license:asl2.0))))
-(define-public rust-fragile-1
+(define-public rust-fragile-2
(package
(name "rust-fragile")
- (version "1.0.0")
+ (version "2.0.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "fragile" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+ (base32 "1ajfdnwdn921bhjlzyvsqvdgci8ab40ln6w9ly422lf8svb428bc"))))
(build-system cargo-build-system)
- (arguments `(#:skip-build? #t))
- (home-page "https://github.com/mitsuhiko/rust-fragile")
+ (arguments
+ `(#:cargo-inputs (("rust-slab" ,rust-slab-0.4))))
+ (home-page "https://github.com/mitsuhiko/fragile")
(synopsis "Wrapper types for sending non-send values to other threads")
(description "This package provides wrapper types for sending non-send
values to other threads.")
(license license:asl2.0)))
+(define-public rust-fragile-1
+ (package
+ (inherit rust-fragile-2)
+ (name "rust-fragile")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "fragile" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1wlihmkjyhvl5rckal32p010piy1l15s6l81h7z31jcd971kk839"))))
+ (arguments `(#:skip-build? #t))))
+
(define-public rust-freetype-0.7
(package
(name "rust-freetype")