aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-22 13:10:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:52 +0000
commitbdf729ab1eed9d2ecfd2f18e4ea6dbbfa90b2bb8 (patch)
tree1a9cd1ff66cc717c94653ca6f39e9ae606cdce38
parent0a4e3c8041cf6f01f1c58eefc5c571b0025ddbe9 (diff)
downloadguix-bdf729ab1eed9d2ecfd2f18e4ea6dbbfa90b2bb8.tar.gz
guix-bdf729ab1eed9d2ecfd2f18e4ea6dbbfa90b2bb8.zip
gnu: Add go-github-com-xtaci-smux.
* gnu/packages/golang-web.scm (go-github-com-xtaci-smux): New variable. Change-Id: I62ddb7898eba295ba773579dcd84704e54f2d408
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 7d7ab217e1..553107157e 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -5744,6 +5744,34 @@ programming language.")
programming language, which supports draft-04, draft-06 and draft-07.")
(license license:asl2.0)))
+(define-public go-github-com-xtaci-smux
+ (package
+ (name "go-github-com-xtaci-smux")
+ (version "1.5.30")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/xtaci/smux")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1i4h672vmg2b4p8hkbhpsp8p2nk4d3qm6vf76yly389l2zb7h4l3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/xtaci/smux"))
+ (home-page "https://github.com/xtaci/smux")
+ (synopsis "Introduction")
+ (description
+ "Smux (@strong{S}imple @strong{MU}ltiple@strong{X}ing) is a multiplexing
+library for Golang. It relies on an underlying connection to provide
+reliability and ordering, such as TCP or
+@url{https://github.com/xtaci/kcp-go,KCP}, and provides stream-oriented
+multiplexing. The original intention of this library is to power the
+connection management for @url{https://github.com/xtaci/kcp-go,kcp-go}.")
+ (license license:expat)))
+
(define-public go-go-opentelemetry-io-otel
(package
(name "go-go-opentelemetry-io-otel")