aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:10:48 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:33 +0200
commitbb0a714271f72b91f9f3745b0cbf8c73a1a998c0 (patch)
tree8581fa6b2ca02d0dc6d50956d86a7fc8cb61ad35
parent87029a6031dc3bb3ffa436509fd91acbc95d242e (diff)
downloadguix-bb0a714271f72b91f9f3745b0cbf8c73a1a998c0.tar.gz
guix-bb0a714271f72b91f9f3745b0cbf8c73a1a998c0.zip
gnu: Add texlive-installfont.
* gnu/packages/tex.scm (texlive-installfont): New variable.
-rw-r--r--gnu/packages/tex.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4fd56bfa13..c1c30cef44 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2355,6 +2355,32 @@ support for indexing. For example, it supports multiple indexes in a single
document and provides a more robust @code{\\index} command.")
(license license:lppl1.2+))) ;from "index.dtx"
+(define-public texlive-installfont
+ (package
+ (name "texlive-installfont")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/support/installfont/"
+ "scripts/installfont/")
+ (base32
+ "0wgksqg88hdzfvrywrv91al9skpj2vly09ly7qmzahqsyvdgmb9p")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "installfont-tl")))
+ (home-page "https://ctan.org/pkg/installfont")
+ (synopsis "Bash script for installing a LaTeX font family")
+ (description
+ "With this script you can install a LaTeX font family (PostScript Type 1,
+TrueType and OpenType formats are supported). Font series from light to ultra
+bold, and (faked) small caps and (faked) slanted shapes are supported, but not
+expert fonts. The script will rename the fonts automatically (optional) or
+will otherwise expect the @file{.afm} files and the font files (in PostScript
+Type1 format) named in the Karl Berry scheme (e.g., @file{5bbr8a.pfb}). After
+running the script, you should have a working font installation in your local
+TeX tree.")
+ (license license:lppl)))
+
(define-public texlive-dvipdfmx
(package
(name "texlive-dvipdfmx")