aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-24 17:16:00 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-24 17:41:09 +0200
commitb9df95614d44216b7202a49af62edcb6f0508b63 (patch)
treebcbb35c5550a5e1b675296c856757f4a01da81b5
parent6277c7574baa806146df4ce32ac026e93e661634 (diff)
downloadguix-b9df95614d44216b7202a49af62edcb6f0508b63.tar.gz
guix-b9df95614d44216b7202a49af62edcb6f0508b63.zip
gnu: emacs-logos: Update to 1.1.0.
* gnu/packages/emacs-xyz.scm (emacs-logos): Update to 1.1.0.
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 31 insertions, 34 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 540874f61a..10659cfcb2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16258,43 +16258,40 @@ view your Denote directory.")
(license license:gpl3+)))
(define-public emacs-logos
- ;; XXX: Upstream did not tag latest release. Use the commit matching
- ;; version bump.
- (let ((commit "d8f18f74591ffcac6466409ac7cd29f90838b2fe"))
- (package
- (name "emacs-logos")
- (version "1.0.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~protesilaos/logos")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0g3jxzwv99wkxlb36j2nyjibayvwjpy7qc2mz9lfd2945q6apj3z"))))
- (native-inputs (list texinfo))
- (build-system emacs-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'install 'makeinfo
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "emacs"
- "--batch"
- "--eval=(require 'ox-texinfo)"
- "--eval=(find-file \"README.org\")"
- "--eval=(org-texinfo-export-to-info)")
- (install-file "logos.info" (string-append #$output "/share/info")))))))
- (home-page "https://protesilaos.com/emacs/logos")
- (synopsis "Simple focus mode for Emacs")
- (description "This package provides a simple focus mode which can be
+ (package
+ (name "emacs-logos")
+ (version "1.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~protesilaos/logos")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "08y63v7qsxw4g0gv01dq05j96ngajln6sv50nssjfwag8bgl4ydi"))))
+ (native-inputs (list texinfo))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'makeinfo
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "emacs"
+ "--batch"
+ "--eval=(require 'ox-texinfo)"
+ "--eval=(find-file \"README.org\")"
+ "--eval=(org-texinfo-export-to-info)")
+ (install-file "logos.info" (string-append #$output "/share/info")))))))
+ (home-page "https://protesilaos.com/emacs/logos")
+ (synopsis "Simple focus mode for Emacs")
+ (description "This package provides a simple focus mode which can be
applied to any buffer for reading, writing, or even doing a presentation. The
buffer can be divided in pages using the @code{page-delimiter}, outline
structure, or any other pattern.")
- (license (list license:gpl3+
- license:fdl1.3+))))) ; GFDLv1.3+ for the manual
+ (license (list license:gpl3+
+ license:fdl1.3+)))) ; GFDLv1.3+ for the manual
(define-public emacs-tmr
(package