aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 17:14:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 17:17:17 +0000
commitb99df83c591104655a6b387817d8f7bb3c50204c (patch)
tree5b800a5a5df8e4ba67918ec0588555ca16986f41
parentb88c907378d63c1f4fac2b871270cf128bbc24df (diff)
downloadguix-b99df83c591104655a6b387817d8f7bb3c50204c.tar.gz
guix-b99df83c591104655a6b387817d8f7bb3c50204c.zip
gnu: go-github-com-charlievieth-fastwalk: Skip tests on non 64bit.
As seen in <https://ci.guix.gnu.org/build/8739944/log/raw>. * gnu/packages/golang-xyz.scm (go-github-com-charlievieth-fastwalk) [arguments] <tests?>: Skip tests on non 64bit systems. Change-Id: I083ba30af74fcf96110c5a515efe9217ebce2a75
-rw-r--r--gnu/packages/golang-xyz.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 79abd0f175..a74d82dbb8 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2503,6 +2503,10 @@ over strings.")
(build-system go-build-system)
(arguments
(list
+ ;; github.com/charlievieth/fastwalk/fastwalk_test.go:962:48: cannot use
+ ;; math.MaxUint32 (untyped int constant 4294967295) as int value in
+ ;; argument to fmt.Sprintf (overflows).
+ #:tests? (target-64bit?)
#:import-path "github.com/charlievieth/fastwalk"))
(home-page "https://github.com/charlievieth/fastwalk")
(synopsis "Fast directory traversal for Golang")