aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-27 18:54:32 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:23 +0200
commitb95b7ee0178af9898045a1956c49f89ff58e43c3 (patch)
treeda15aac52325875182376f603f28ddfc0bb46088
parent18325381539888df5295bed5565e232f3c383eb0 (diff)
downloadguix-b95b7ee0178af9898045a1956c49f89ff58e43c3.tar.gz
guix-b95b7ee0178af9898045a1956c49f89ff58e43c3.zip
gnu: Add texlive-hitex-bin.
* gnu/packages/tex.scm (texlive-hitex-bin): New variable. (texlive-hitex)[propagated-inputs]: Add TEXLIVE-HITEX-BIN. Change-Id: I1d116623970d60261b366c5c48e05b2dcf53fbde
-rw-r--r--gnu/packages/tex.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index d23f039a74..1ab2b1964d 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -16774,6 +16774,7 @@ Indian Type Foundry, with support for LaTeX and pdfLaTeX.")
texlive-etex
texlive-everyshi
texlive-firstaid
+ texlive-hitex-bin
texlive-hyphen-base
texlive-knuth-lib
texlive-l3backend
@@ -16800,6 +16801,35 @@ TeX to format a document for nearly-arbitrary values of @code{\\hsize} and
@code{\\vsize}.")
(license license:x11)))
+(define-public texlive-hitex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-hitex-bin")
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--disable-web2c"
+ "--enable-hitex"
+ (delete "--disable-hitex"
+ (delete "--enable-web2c" #$flags))))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "texk/web2c"
+ (let ((bin (string-append #$output "/bin"))
+ (files '("hishrink" "histretch" "hitex")))
+ (for-each (lambda (f) (invoke "make" f)) files)
+ (for-each (lambda (f) (install-file f bin)) files)
+ (with-directory-excursion bin
+ (symlink "hitex" "hilatex"))))))))))
+ (native-inputs (list pkg-config))
+ (home-page (package-home-page texlive-hitex))
+ (synopsis "Binaries for @code{texlive-hitex}")
+ (description
+ "This package provides the binaries for @code{texlive-hitex}.")
+ (license (package-license texlive-hitex))))
+
(define-public texlive-hitszbeamer
(package
(name "texlive-hitszbeamer")