aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2024-11-02 12:36:39 +0800
committerHilton Chain <hako@ultrarare.space>2024-12-02 07:42:20 +0800
commitb91b992ed07a2a3440a8722d74897a3c3c09ec2a (patch)
tree92c30ba7014045565acc1cd2e1d62fdb40bc2362
parent858dd7e721d69a6087375395037a86640418f1fb (diff)
downloadguix-b91b992ed07a2a3440a8722d74897a3c3c09ec2a.tar.gz
guix-b91b992ed07a2a3440a8722d74897a3c3c09ec2a.zip
gnu: redis: Update to 7.2.6.
* gnu/packages/databases.scm (redis): Update to 7.2.6. [arguments]<#:phases>: Update failing tests. Change-Id: Ife107541697fda4f0928497560871f8ffb07d445
-rw-r--r--gnu/packages/databases.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 142f9090c5..b15ad5dbe1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2600,14 +2600,14 @@ similar to BerkeleyDB, LevelDB, etc.")
(define-public redis
(package
(name "redis")
- (version "7.0.12")
+ (version "7.2.6")
(source (origin
(method url-fetch)
(uri (string-append "https://download.redis.io/releases/redis-"
version".tar.gz"))
(sha256
(base32
- "1dwayif99cipf0xs26zipbnj800px31pbsxz747bzclb4xdkvn4x"))
+ "03ixkzdc43lr4q3my0yax1f1gqz6sr6hch5qdipmbd725xxdc47v"))
(modules '((guix build utils)))
(snippet
;; Delete bundled jemalloc, as the package will use the libc one
@@ -2638,15 +2638,13 @@ similar to BerkeleyDB, LevelDB, etc.")
;; "background AOF rewrite to finish", perhaps because dead
;; processes persist as zombies in the build environment.
(("unit/aofrw") "")
+ (("integration/aof([^-]|-multi-part)") "")
;; The OOM score tests try to raise the current OOM score, but
;; our build environment already sets it for all children to
;; the highest possible one (1000). We can't lower it because
;; we don't have CAP_SYS_RESOURCE.
(("unit/oom-score-adj") "")
- (("integration/aof(-multi-part)?") "")
(("integration/failover") "")
- (("integration/replication-4") "")
- (("integration/replication-psync") "")
(("integration/replication[^-]") "")))))))
(native-inputs (list pkg-config procps tcl which))
(synopsis "Key-value cache and store")