aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-04 20:51:44 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:59 +0000
commitb909977f5fa2c9ee21cc2ac59916fced0ec500c7 (patch)
tree984b19419a6da8061d798f72e7579a0ed1252859
parentbb3dbcde48c6f19100726545c43687f0d37fa620 (diff)
downloadguix-b909977f5fa2c9ee21cc2ac59916fced0ec500c7.tar.gz
guix-b909977f5fa2c9ee21cc2ac59916fced0ec500c7.zip
gnu: python-kiwisolver: Update to 1.4.6.
* gnu/packages/maths.scm (python-kiwisolver): Update to 1.4.6. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Iafc09eb96ac72ee7094ead36e284994798d544a2
-rw-r--r--gnu/packages/maths.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f17b69c284..17b4941bc4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -3895,16 +3895,22 @@ programming language.")
(define-public python-kiwisolver
(package
(name "python-kiwisolver")
- (version "1.4.5")
+ (version "1.4.6")
(source (origin
(method url-fetch)
(uri (pypi-uri "kiwisolver" version))
(sha256
(base32
- "1v6nc0z9dg4am0bibji9pijci9f15z68mwrlv91a28pvawx5czp5"))))
+ "1q77r6cl9m4vh8lsvmsm1ijh3r9aijdhmnc03yhnlpj407b2kniw"))))
(build-system pyproject-build-system)
- (propagated-inputs (list python-typing-extensions))
- (native-inputs (list python-cppy python-pytest python-setuptools-scm))
+ (native-inputs
+ (list python-cppy
+ python-pytest
+ python-setuptools
+ python-setuptools-scm
+ python-wheel))
+ (propagated-inputs
+ (list python-typing-extensions))
(home-page "https://github.com/nucleic/kiwi")
(synopsis "Fast implementation of the Cassowary constraint solver")
(description