aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 10:59:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-21 16:28:43 +0200
commitb816c2577fa30099e2dcd501f1a4a53b0f2bc686 (patch)
tree40abf74e850136e57d823f48d72887557ea415e9
parent128b7175b4886c099c63a07b451b97a35c6c0fc7 (diff)
downloadguix-b816c2577fa30099e2dcd501f1a4a53b0f2bc686.tar.gz
guix-b816c2577fa30099e2dcd501f1a4a53b0f2bc686.zip
gnu: Add texlive-bboldx.
* gnu/packages/tex.scm (texlive-bboldx): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index ac55fe9f51..bc4e0580dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3891,6 +3891,33 @@ versions of the @code{bbold} fonts.")
;; distribute this file".
(license (license:fsf-free "file:doc/fonts/bbold-type1/README"))))
+(define-public texlive-bboldx
+ (package
+ (name "texlive-bboldx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/bboldx/"
+ "fonts/afm/public/bboldx/"
+ "fonts/enc/dvips/bboldx/"
+ "fonts/map/dvips/bboldx/"
+ "fonts/tfm/public/bboldx/"
+ "fonts/type1/public/bboldx/"
+ "tex/latex/bboldx/")
+ (base32
+ "1r4s3yyah0iqwhzss52wjv3wml5r4bywp3fbanjzkv16f2pk51yb")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/bboldx")
+ (synopsis "Extend the @code{bbold} package with a Blackboard Bold alphabet")
+ (description
+ "This is an extension of @code{bbold} to a package with three weights,
+of which the original is considered as light and the additions as regular and
+bold.")
+ ;; The README states: "You may freely use, modify and/or
+ ;; distribute this file".
+ (license (license:fsf-free "file://doc/fonts/bboldx/README"))))
+
(define-public texlive-bclogo
(package
(name "texlive-bclogo")