aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEkaitz Zarraga <ekaitz@elenq.tech>2024-12-20 23:11:17 +0100
committerEkaitz Zarraga <ekaitz@elenq.tech>2024-12-20 23:31:38 +0100
commitb6c68f6660173c51b4bb53ac230ec922137a8c45 (patch)
tree505223a78c4a4aad412c52ad35453743ff726330
parentfdcb67250af3df91b3ef090915ba32fe22cce86e (diff)
downloadguix-b6c68f6660173c51b4bb53ac230ec922137a8c45.tar.gz
guix-b6c68f6660173c51b4bb53ac230ec922137a8c45.zip
gnu: Add guile-libnotify.
* gnu/packages/guile-xyz.scm (guile-libnotify): New variable. Change-Id: I675b5952957e6205786a950a8dc90f507e43cdfb
-rw-r--r--gnu/packages/guile-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 05af36b3e8..dd0f620133 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -6325,6 +6325,27 @@ create GraphQL schemas, an execution engine to execute GraphQL queries, and a
HTTP handler to implement a HTTP GraphQL endpoint.")
(license license:agpl3+)))
+(define-public guile-libnotify
+ (package
+ (name "guile-libnotify")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ekaitz-zarraga/guile-libnotify")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "055d3xjx819yr1mhph3lvciqn17hxmqrh3vp8cjz4905yr0bf7r2"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf automake pkg-config texinfo))
+ (inputs (list guile-3.0 libnotify))
+ (synopsis "Guile bindings for libnotify")
+ (description "Provides bindings for GNOME's libnotify C library to Guile")
+ (home-page "https://github.com/ekaitz-zarraga/guile-libnotify")
+ (license license:gpl3+)))
+
(define-public lokke
(let ((commit "92d36370dc6d218ff3bf315e56ebef93808c1b79")
(revision "1"))