aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-03-05 22:10:54 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-29 15:08:06 +0000
commitb548c6b1d576509c78479219c7af6b57b43df7f0 (patch)
treead3f326bbbb6600f7b4a2937369734a7ef3bf227
parenta2894745a5feaf9adb20c3f7a8f1e5ba78d41f16 (diff)
downloadguix-b548c6b1d576509c78479219c7af6b57b43df7f0.tar.gz
guix-b548c6b1d576509c78479219c7af6b57b43df7f0.zip
gnu: python-pytest-doctestplus: Update to 1.2.0.
* gnu/packages/python-check.scm (python-pytest-doctestplus): Update to 1.2.0. [arguments] <#:test-flags>: Disable one more failing test. [home-page]: Update accordingly with lint warning. Change-Id: I353a671741cf887c348d627d9e071e3fedcc4edc
-rw-r--r--gnu/packages/python-check.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 69663f67e9..d62e6f634a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -605,26 +605,29 @@ running the tests.")
(define-public python-pytest-doctestplus
(package
(name "python-pytest-doctestplus")
- (version "1.0.0")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-doctestplus" version))
(sha256
- (base32 "17ylfnrcvvp6sd13bfj40jl40paqmjsbywysszb3xqgdr86l8l7n"))))
+ (base32 "0cmrkgpib869kpy8h8hfkg20w16lakkmbkw8cxdywpmf5wx7dbf5"))))
(build-system pyproject-build-system)
(arguments
(list #:test-flags
#~(list "-k" (string-append
+ ;; Tests requiring network access.
"not test_remote_data_url"
" and not test_remote_data_float_cmp"
" and not test_remote_data_ignore_whitespace"
" and not test_remote_data_ellipsis"
" and not test_remote_data_requires"
- " and not test_remote_data_ignore_warnings"))))
+ " and not test_remote_data_ignore_warnings"
+ ;; Requiring git available.
+ " and not test_generate_diff_basic"))))
(native-inputs
(list python-numpy python-pytest python-setuptools-scm))
- (home-page "https://github.com/astropy/pytest-doctestplus")
+ (home-page "https://github.com/scientific-python/pytest-doctestplus")
(synopsis "Pytest plugin with advanced doctest features")
(description
"This package contains a plugin for the Pytest framework that provides