aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 18:58:38 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:30 +0200
commitb4cd894d36001ea4ecfaee25f06116a5036b66db (patch)
tree6c8d867fbc3b978574b4d95d304cffec0d2e0757
parent92ea6d7d6b5cf87f174b2fc32dd6ed68a9e5b96b (diff)
downloadguix-b4cd894d36001ea4ecfaee25f06116a5036b66db.tar.gz
guix-b4cd894d36001ea4ecfaee25f06116a5036b66db.zip
gnu: texlive-utopia: Refresh package definition.
* gnu/packages/tex.scm (texlive-utopia): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm34
1 files changed, 18 insertions, 16 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 6d1c3d05c4..b8ca68c149 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11190,23 +11190,25 @@ trademark of Adobe Systems Incorporated.")
(define-public texlive-utopia
(package
- (inherit (simple-texlive-package
- "texlive-utopia"
- (list "/doc/fonts/utopia/"
- "/fonts/afm/adobe/utopia/"
- "/fonts/tfm/adobe/utopia/"
- "/fonts/type1/adobe/utopia/"
- "/fonts/vf/adobe/utopia/")
- (base32
- "113wgkfz4z0ls2grxxfj17l42a1yv9r5ipcd0156xnfsrqvqzxfc")
- #:trivial? #t))
- (home-page "https://www.ctan.org/pkg/utopia")
+ (name "texlive-utopia")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/fonts/utopia/" "fonts/afm/adobe/utopia/"
+ "fonts/tfm/adobe/utopia/"
+ "fonts/type1/adobe/utopia/"
+ "fonts/vf/adobe/utopia/")
+ (base32
+ "113wgkfz4z0ls2grxxfj17l42a1yv9r5ipcd0156xnfsrqvqzxfc")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/utopia")
(synopsis "Adobe Utopia fonts")
- (description "The Adobe Standard Encoding set of the Utopia font
-family, as contributed to the X Consortium. The set comprises upright
-and italic shapes in medium and bold weights. Macro support and
-matching maths fonts are provided by the @code{fourier} and
-@code{mathdesign} font packages.")
+ (description
+ "The Adobe Standard Encoding set of the Utopia font family, as
+contributed by the X Consortium. The set comprises upright and italic shapes
+in medium and bold weights. Macro support and matching maths fonts are
+provided by the @code{fourier} and the @code{mathdesign} font packages.")
(license (license:fsf-free
"http://mirrors.ctan.org/fonts/utopia/README"))))