aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:19:08 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:35 +0200
commitb37e07414b53150417ff243fd87dd2357ee56e3e (patch)
treeae8a56358d1d9c1a7c9e1e9b6ccb05d9fa82a594
parentf32be4aa97eae58923c1613e88610e044a080207 (diff)
downloadguix-b37e07414b53150417ff243fd87dd2357ee56e3e.tar.gz
guix-b37e07414b53150417ff243fd87dd2357ee56e3e.zip
gnu: Add texlive-pictex2.
* gnu/packages/tex.scm (texlive-pictex2): New variable.
-rw-r--r--gnu/packages/tex.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3b447f1df4..83cef56957 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3320,6 +3320,26 @@ to run out of space; packages @code{m-pictex} and @code{pictexwd} deal with
the problems in different ways.")
(license license:lppl1.0+)))
+(define-public texlive-pictex2
+ (package
+ (name "texlive-pictex2")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "tex/latex/pictex2/")
+ (base32
+ "1qqf08yharknq6csk01jdff62mg011bryqlq5mbmjwqwh7wxs0wy")))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pictex2")
+ (synopsis "Adds relative coordinates and improves the @code{\\plot} command")
+ (description
+ "This package adds two user commands to standard PiCTeX. One command
+uses relative coordinates, thus eliminating the need to calculate the
+coordinate of every point manually as in standard PiCTeX. The other command
+modifies @code{\\plot} to use a rule instead of dots if the line segment is
+horizontal or vertical.")
+ (license license:lppl)))
+
(define-public texlive-amiri
(package
(name "texlive-amiri")