aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:16 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:57 +0000
commitb3435d3ed1a23a44153824fd78b6ff18a19c8cce (patch)
tree71b456ba1f6c4c6d6547c634da0004feaba35897
parent23cb0c203c368a40a1db49de2581ea59d12d899e (diff)
downloadguix-b3435d3ed1a23a44153824fd78b6ff18a19c8cce.tar.gz
guix-b3435d3ed1a23a44153824fd78b6ff18a19c8cce.zip
gnu: python-fenics-dijitso: Move to pyproject-build-system.
* gnu/packages/simulation.scm (python-fenics-dijitso): [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Rewrite check phase replacement to care about .guix-pytest. Change-Id: I3383f4078fbb0100e6d8257d7d84785b953ab0cf Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/simulation.scm19
1 files changed, 10 insertions, 9 deletions
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index f3f6ee40fc..379516d2ff 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -565,7 +565,7 @@ some support for generating and analysing traffic scenarios..")
(sha256
(base32
"0lhqsq8ypdak0ahr2jnyvg07yrqp6wicjxi6k56zx24wp3qg60sc"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(inputs
(list openmpi python-numpy))
(native-inputs
@@ -578,15 +578,16 @@ some support for generating and analysing traffic scenarios..")
(add-after 'build 'mpi-setup
,%openmpi-setup)
(replace 'check
- (lambda _
+ (lambda* (#:key inputs #:allow-other-keys)
(setenv "HOME" "/tmp")
- (with-directory-excursion "test"
- ;; Disable parallel tests to avoid race condition. See
- ;; https://github.com/pytest-dev/pytest-cov/issues/237.
- (substitute* "runtests.sh"
- (("for p in 1 4 8 16; do")
- "for p in 1; do"))
- (invoke "./runtests.sh")))))))
+ (with-guix-pytest-plugin inputs
+ (with-directory-excursion "test"
+ ;; Disable parallel tests to avoid race condition. See
+ ;; https://github.com/pytest-dev/pytest-cov/issues/237.
+ (substitute* "runtests.sh"
+ (("for p in 1 4 8 16; do")
+ "for p in 1; do"))
+ (invoke "./runtests.sh"))))))))
(home-page "https://bitbucket.org/fenics-project/dijitso/")
(synopsis "Distributed just-in-time building of shared libraries")
(description