aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2024-11-05 23:23:50 +0100
committerVagrant Cascadian <vagrant@debian.org>2024-12-10 22:34:58 -0800
commitb158f3fb7acb8a9677898e3cfffd21abf55dbafa (patch)
treedf1822a83a402e09c3000530a6c2a3d186c19719
parent44cc1295752edb7711471dce4872c41d740d10d0 (diff)
downloadguix-b158f3fb7acb8a9677898e3cfffd21abf55dbafa.tar.gz
guix-b158f3fb7acb8a9677898e3cfffd21abf55dbafa.zip
gnu: Fix synopsis in rust packages.
* gnu/packages/crates-crypto.scm (rust-curve25519-dalek-derive-0.1): Fix synopsis. * gnu/packages/crates-graphics.scm (rust-x11-clipboard-0.9): Fix synopsis. * gnu/packages/crates-io.scm (rust-abi-stable-derive-0.11): Fix synopsis. (rust-anstyle-lossy-1): Fix synopsis. (rust-anstyle-stream-0.2): Fix synopsis. (rust-assert2-0.3): Fix synopsis. (rust-backtrace-ext-0.2): Fix synopsis. (rust-carapace-spec-clap-0.1): Fix synopsis. (rust-circular-0.3): Fix synopsis. (rust-const-sha1-0.2): Fix synopsis. (rust-cpuid-bool-0.2): Fix synopsis. (rust-ctor-0.2): Fix synopsis. (rust-enum-iterator-1): Fix synopsis. (rust-hyprland-0.3): Fix synopsis. (rust-is-debug-1): Fix synopsis. (rust-kqueue-1): Fix synopsis. (rust-pico-args-0.5): Fix synopsis. (rust-pnet-base-0.34): Fix synopsis. (rust-postcard-1): Fix synopsis. (rust-profiling-procmacros-1): Fix synopsis. (rust-pyproject-toml-0.8): Fix synopsis. (rust-railroad-0.2): Fix synopsis. (rust-rstest-macros-0.18): Fix synopsis. (rust-rustdoc-json-0.8): Fix synopsis. (rust-serde-big-array-0.5): Fix synopsis. (rust-structmeta-0.2): Fix synopsis. (rust-subplotlib-derive-0.7): Fix synopsis. (rust-sval-ref-2): Fix synopsis. (rust-thiserror-1): Fix synopsis. (rust-thiserror-core-1): Fix synopsis. (rust-thousands-0.2): Fix synopsis. (rust-tokio-uring-0.4): Fix synopsis. (rust-ubyte-0.10): Fix synopsis. (rust-udev-0.7): Fix synopsis. (rust-ufmt-macros-0.3): Fix synopsis. (rust-ufmt-write-0.1): Fix synopsis. (rust-urlencoding-2): Fix synopsis. * gnu/packages/crates-web.scm (rust-hyper-native-tls-0.3): Fix synopsis. (rust-tonic-0.10): Fix synopsis. (rust-trust-dns-native-tls-0.20): Fix synopsis. (rust-trust-dns-openssl-0.20): Fix synopsis. (rust-trust-dns-rustls-0.20): Fix synopsis. (rust-wiremock-0.5): Fix synopsis. Signed-off-by: Vagrant Cascadian <vagrant@debian.org>
-rw-r--r--gnu/packages/crates-crypto.scm2
-rw-r--r--gnu/packages/crates-graphics.scm2
-rw-r--r--gnu/packages/crates-io.scm79
-rw-r--r--gnu/packages/crates-web.scm12
4 files changed, 52 insertions, 43 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 150861fc4b..995b183652 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -1924,7 +1924,7 @@ on ristretto255 and Curve25519.")
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-2))))
(home-page "https://doc.dalek.rs/curve25519_dalek")
- (synopsis "curve25519-dalek Derives")
+ (synopsis "Derives of curve25519-dalek")
(description "This package provides curve25519-dalek Derives.")
(license (list license:expat license:asl2.0))))
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 757e23f81e..9ea45c6db6 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -6454,7 +6454,7 @@ the platform-specific getters provided by winit, or another library.")
(system (string-append xvfb " " display " &"))))))))
(native-inputs (list xorg-server-for-tests))
(home-page "https://github.com/quininer/x11-clipboard")
- (synopsis "x11 clipboard support for Rust")
+ (synopsis "X11 clipboard support for Rust")
(description "This package provides x11 clipboard support for Rust.")
(license license:expat)))
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 07893eaac7..b94cc9a60a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -302,7 +302,7 @@ loaded at program startup.")
#:cargo-development-inputs
(("rust-as-derive-utils" ,rust-as-derive-utils-0.11))))
(home-page "https://github.com/rodrimati1992/abi_stable_crates/")
- (synopsis "Implementation detail of abi_stable.")
+ (synopsis "Implementation detail of abi_stable")
(description "This package contains an implementation detail of abi_stable.")
(license (list license:expat license:asl2.0))))
@@ -2144,7 +2144,7 @@ text to a terminal.")
(arguments
`(#:cargo-inputs (("rust-anstyle" ,rust-anstyle-1))))
(home-page "https://github.com/rust-cli/anstyle")
- (synopsis "conversion between ANSI color codes")
+ (synopsis "Conversion between ANSI color codes")
(description "Lossy conversion between ANSI Color Codes.")
(license (list license:expat license:asl2.0))))
@@ -2249,7 +2249,7 @@ text to a terminal.")
("rust-proptest" ,rust-proptest-1)
("rust-strip-ansi-escapes" ,rust-strip-ansi-escapes-0.1))))
(home-page "https://github.com/rust-cli/anstyle")
- (synopsis "Library for writing colored text to a terminal.")
+ (synopsis "Library for writing colored text to a terminal")
(description "This package provides a simple cross platform library for
writing colored text to a terminal.")
(license (list license:expat license:asl2.0))))
@@ -4806,7 +4806,7 @@ variables from the pattern into scope.")
("rust-is-terminal" ,rust-is-terminal-0.4)
("rust-yansi" ,rust-yansi-0.5))))
(home-page "https://github.com/de-vri-es/assert2-rs")
- (synopsis "assert!(...) and check!(...) macros inspired by Catch2")
+ (synopsis "Macros inspired by Catch2")
(description "This package provides assert!(...) and check!(...) macros
inspired by Catch2.")
(license license:bsd-2)))
@@ -6959,7 +6959,7 @@ trace (backtrace) at runtime in a Rust program.")
#:cargo-development-inputs (("rust-miette" ,rust-miette-5)
("rust-thiserror" ,rust-thiserror-1))))
(home-page "https://github.com/gankra/backtrace-ext")
- (synopsis "conveniences on top of the backtrace crate")
+ (synopsis "Conveniences on top of the backtrace crate")
(description
"This package provides minor conveniences on top of the backtrace crate.")
(license (list license:expat license:asl2.0))))
@@ -11752,7 +11752,7 @@ capabilities.")
("rust-serde-yaml" ,rust-serde-yaml-0.9))
#:cargo-development-inputs (("rust-snapbox" ,rust-snapbox-0.4))))
(home-page "https://github.com/rsteube/carapace-spec-clap")
- (synopsis "spec generation for clap-rs/clap")
+ (synopsis "Spec generation for clap-rs/clap")
(description "This package provides spec generation for clap-rs/clap.")
(license license:expat)))
@@ -13460,7 +13460,7 @@ interoperation between crates in Rust.")
(base32 "1slb0zd1xj0fjd0ql86zs57l1xbn5ywsyj1d8397bcvc1yg27z5h"))))
(build-system cargo-build-system)
(home-page "https://github.com/sozu-proxy/circular")
- (synopsis "stream abstraction for nom")
+ (synopsis "Stream abstraction for nom")
(description
"This package provides a stream abstraction designed for use with nom.")
(license license:expat)))
@@ -16494,7 +16494,7 @@ generation.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/rylev/const-sha1")
- (synopsis "sha1 implementation for use in const contexts")
+ (synopsis "SHA1 implementation for use in const contexts")
(description
"This package provides a sha1 implementation for use in const contexts.")
(license (list license:asl2.0 license:expat))))
@@ -17510,7 +17510,7 @@ to the @code{is_x86_feature_detected!} macro.")
;; error: This crate works only on x86 and x86-64 targets.
(list #:skip-build? (not (target-x86?))))
(home-page "https://github.com/RustCrypto/utils/tree/master/cpufeatures")
- (synopsis "replaced by the `cpufeatures` crate")
+ (synopsis "Replaced by the `cpufeatures` crate")
(description "This package has been replaced by the `cpufeatures` crate.")
(license (list license:expat license:asl2.0))))
@@ -19426,7 +19426,7 @@ use with sct crate.")
#:cargo-development-inputs
(("rust-libc-print" ,rust-libc-print-0.1))))
(home-page "https://github.com/mmastrac/rust-ctor")
- (synopsis "__attribute__((constructor)) for Rust")
+ (synopsis "Rust's __attribute__((constructor))")
(description
"This package provides an @code{__attribute__((constructor))} for Rust.")
(license (list license:asl2.0 license:expat))))
@@ -25014,7 +25014,7 @@ increasing their method call speed up to 10x.")
`(#:cargo-inputs (("rust-enum-iterator-derive" ,rust-enum-iterator-derive-1))))
(home-page "https://github.com/stephaneyfx/enum-iterator")
(synopsis
- "Tools to iterate over all values of a type (e.g. all variants of an
+ "Iterate over all values of a type (e.g. all variants of an
enumeration)")
(description
"This package provides tools to iterate over all values of a
@@ -34695,7 +34695,7 @@ SystemTime}}.")
("rust-strum" ,rust-strum-0.26)
("rust-tokio" ,rust-tokio-1))))
(home-page "https://github.com/hyprland-community/hyprland-rs")
- (synopsis "An unofficial rust wrapper for Hyprland's IPC")
+ (synopsis "Unofficial rust wrapper for Hyprland's IPC")
(description
"This package provides a unoffical rust wrapper for hyprland's IPC.")
(license license:gpl3+)))
@@ -37075,8 +37075,8 @@ Rust.")
(build-system cargo-build-system)
(arguments `(#:skip-build? #t))
(home-page "https://github.com/baoyachi/rust_is_debug")
- (synopsis "get build model is debug")
(description "get build model is debug")
+ (synopsis "Get build model is debug")
(license (list license:expat license:asl2.0))))
(define-public rust-is-docker-0.2
@@ -38735,7 +38735,7 @@ passwords/credentials.")
#:cargo-development-inputs
(("rust-tempfile" ,rust-tempfile-3))))
(home-page "https://gitlab.com/worr/rust-kqueue")
- (synopsis "kqueue interface for BSDs")
+ (synopsis "BSDs kqueue interface")
(description "This package provides a kqueue interface for BSDs.")
(license license:expat)))
@@ -56229,7 +56229,7 @@ function data structures.")
(base32 "05d30pvxd6zlnkg2i3ilr5a70v3f3z2in18m67z25vinmykngqav"))))
(build-system cargo-build-system)
(home-page "https://github.com/RazrFalcon/pico-args")
- (synopsis "CLI arguments parser.")
+ (synopsis "CLI arguments parser")
(description "This package provides an ultra simple CLI arguments parser.")
(license license:expat)))
@@ -56986,7 +56986,7 @@ both WASM and native applications")
("rust-serde" ,rust-serde-1))
#:cargo-development-inputs (("rust-serde-test" ,rust-serde-test-1))))
(home-page "https://github.com/libpnet/libpnet")
- (synopsis "Fundamental base types and code used by pnet.")
+ (synopsis "Fundamental base types and code used by pnet")
(description
"This crate implements fundamental base types and code used by pnet.")
(license (list license:expat license:asl2.0))))
@@ -58203,7 +58203,7 @@ I/O library.")
("rust-postcard-derive" ,rust-postcard-derive-0.1)
("rust-serde" ,rust-serde-1))))
(home-page "https://github.com/jamesmunns/postcard")
- (synopsis "A no_std + serde compatible message library for Rust")
+ (synopsis "Rust message library compatible with no_std and serde")
(description
"This package provides a no_std + serde compatible message library for Rust.")
(license (list license:expat license:asl2.0))))
@@ -59929,7 +59929,7 @@ possibly blocking tasks.")
`(#:cargo-inputs (("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-2))))
(home-page "https://github.com/aclysma/profiling")
- (synopsis "Abstraction over other profiler crates.")
+ (synopsis "Abstraction over other profiler crates")
(description
"This crate provides a very thin abstraction over other profiler crates.")
(license (list license:expat license:asl2.0))))
@@ -62104,7 +62104,7 @@ Python code from a Rust binary is also supported.")
("rust-serde" ,rust-serde-1)
("rust-toml" ,rust-toml-0.8))))
(home-page "https://github.com/PyO3/pyproject-toml-rs.git")
- (synopsis "pyproject.toml parser in Rust")
+ (synopsis "Rust parser for pyproject.toml")
(description "This package provides a pyproject.toml parser in Rust.")
(license license:expat)))
@@ -63247,7 +63247,7 @@ learnt from TrieMap and Sequence Trie.")
(("rust-lazy-static" ,rust-lazy-static-1)
("rust-railroad-verification" ,rust-railroad-verification-0.1))))
(home-page "https://github.com/lukaslueg/railroad")
- (synopsis "library to create syntax-diagrams as Scalable Vector Graphics")
+ (synopsis "Library to create syntax-diagrams as Scalable Vector Graphics")
(description
"This package provides a library to create syntax-diagrams as Scalable
Vector Graphics.")
@@ -67249,7 +67249,12 @@ procedural macro to implement fixtures and table based tests.")
("rust-pretty-assertions" ,rust-pretty-assertions-1)
("rust-rstest" ,rust-rstest-0.18)
("rust-rstest-reuse" ,rust-rstest-reuse-0.6)
- ("rust-rstest-test" ,rust-rstest-test-0.11))))))
+ ("rust-rstest-test" ,rust-rstest-test-0.11))))
+ (home-page "https://github.com/la10736/rstest")
+ (synopsis "Procedural macros for @code{rstest}")
+ (description
+ "This package provides the procedural macro crate for @code{rstest}.")
+ (license (list license:expat license:asl2.0))))
(define-public rust-rstest-macros-0.17
(package
@@ -69106,7 +69111,7 @@ rustc compiler.")
("rust-tempfile" ,rust-tempfile-3))))
(home-page
"https://github.com/Enselic/cargo-public-api/tree/main/rustdoc-json")
- (synopsis "Utilities for working with rustdoc JSON.")
+ (synopsis "Utilities for working with rustdoc JSON")
(description "Utilities for working with rustdoc JSON.")
(license license:expat)))
@@ -72290,7 +72295,7 @@ formats:
#:cargo-development-inputs (("rust-serde-derive" ,rust-serde-derive-1)
("rust-serde-json" ,rust-serde-json-1))))
(home-page "https://github.com/est31/serde-big-array")
- (synopsis "Big array helper for serde.")
+ (synopsis "Big array helper for serde")
(description "Big array helper for serde.")
(license (list license:expat license:asl2.0))))
@@ -78867,7 +78872,7 @@ for your structs.")
("rust-syn" ,rust-syn-2))
#:cargo-development-inputs (("rust-syn" ,rust-syn-2))))
(home-page "https://github.com/frozenlib/structmeta")
- (synopsis "Parse Rust's attribute arguments by defining a struct.")
+ (synopsis "Parse Rust's attribute arguments by defining a struct")
(description "This package lets you parse Rust's attribute arguments by
defining a struct.")
(license (list license:expat license:asl2.0))))
@@ -79471,7 +79476,7 @@ based test suites. Relies on @code{subplotlib-derive} for associated macros.")
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-2))))
(home-page "https://subplot.tech/")
- (synopsis "macros for constructing subplotlib based test suites")
+ (synopsis "Macros for constructing subplotlib based test suites")
(description
"This package provides macros for constructing subplotlib based test
suites, typically generated by @code{subplot codegen}.")
@@ -79902,7 +79907,7 @@ values without proliferating generics.")
`(#:cargo-inputs (("rust-sval" ,rust-sval-2))
#:cargo-development-inputs (("rust-sval-test" ,rust-sval-test-2))))
(home-page "https://github.com/sval-rs/sval")
- (synopsis "A variant of sval::Value for types with internal references")
+ (synopsis "Variant of sval::Value for types with internal references")
(description
"This package provides a variant of sval::Value for types with internal
references")
@@ -84407,7 +84412,7 @@ handle Unicode characters correctly.")
("rust-rustversion" ,rust-rustversion-1)
("rust-trybuild" ,rust-trybuild-1))))
(home-page "https://github.com/dtolnay/thiserror")
- (synopsis "derive(Error)")
+ (synopsis "Provides @code{derive(Error)}")
(description "This package provides @code{derive(Error)} in Rust.")
(license (list license:expat license:asl2.0))))
@@ -84431,7 +84436,7 @@ handle Unicode characters correctly.")
("rust-rustversion" ,rust-rustversion-1)
("rust-trybuild" ,rust-trybuild-1))))
(home-page "https://github.com/FlorianUekermann/thiserror")
- (synopsis "derive(Error)")
+ (synopsis "Provides @code{derive(Error)}")
(description "This package provides @code{derive(Error)} in Rust.")
(license (list license:expat license:asl2.0))))
@@ -84495,7 +84500,7 @@ handle Unicode characters correctly.")
(arguments
`(#:skip-build? #t))
(home-page "https://github.com/tov/thousands-rs")
- (synopsis "Adds digit separators to numerals, configurably.")
+ (synopsis "Adds digit separators to numerals, configurably")
(description "This package provides thousand separators for numerals.")
(license (list license:expat license:asl2.0))))
@@ -87358,7 +87363,7 @@ stream-based WebSocket implementation.")
("rust-tokio" ,rust-tokio-1)
("rust-tokio-test" ,rust-tokio-test-0.4))))
(home-page "https://tokio.rs")
- (synopsis "io-uring support for the Tokio asynchronous runtime")
+ (synopsis "Tokio asynchronous runtime io-uring support")
(description
"This package provides io-uring support for the Tokio asynchronous runtime.")
(license license:expat)))
@@ -90110,7 +90115,7 @@ system tz database.")
#:cargo-development-inputs (("rust-serde-json" ,rust-serde-json-1)
("rust-serde-test" ,rust-serde-test-1))))
(home-page "https://github.com/SergioBenitez/ubyte")
- (synopsis "no_std library for byte units")
+ (synopsis "Byte units no_std library")
(description
"This package provides a simple, complete, const-everything, saturating,
human-friendly, no_std library for byte units.")
@@ -90233,7 +90238,11 @@ with the Unicode character database.")
("rust-mio" ,rust-mio-0.6)
("rust-mio" ,rust-mio-0.7)
("rust-mio" ,rust-mio-0.8)
- ("rust-pkg-config" ,rust-pkg-config-0.3))))))
+ ("rust-pkg-config" ,rust-pkg-config-0.3))))
+ (home-page "https://github.com/Smithay/udev-rs")
+ (synopsis "Rust libudev bindings")
+ (description "This package provides libudev bindings for Rust.")
+ (license license:expat)))
(define-public rust-udevrs-0.3
(package
@@ -90325,7 +90334,7 @@ panic-free alternative to @code{core::fmt}.")
("rust-quote" ,rust-quote-1)
("rust-syn" ,rust-syn-1))))
(home-page "https://github.com/japaric/ufmt")
- (synopsis "μfmt macros")
+ (synopsis "Rust μfmt macros")
(description "This package provides μfmt macros.")
(license (list license:expat license:asl2.0))))
@@ -90363,7 +90372,7 @@ panic-free alternative to @code{core::fmt}.")
"0sdx0r6ah9xr3nydrqxj01v25sb956c0jk5rqf6f5i9fnkb2wyp8"))))
(build-system cargo-build-system)
(home-page "https://github.com/japaric/ufmt")
- (synopsis "μfmt's uWrite trait")
+ (synopsis "Rust μfmt's uWrite trait")
(description "This package provides @code{μfmt}'s @code{uWrite} trait.")
(license (list license:expat license:asl2.0))))
@@ -91729,7 +91738,7 @@ mile, ...).")
(base32 "1nj99jp37k47n0hvaz5fvz7z6jd0sb4ppvfy3nphr1zbnyixpy6s"))))
(build-system cargo-build-system)
(home-page "https://lib.rs/urlencoding")
- (synopsis "A Rust library for doing URL percentage encoding.")
+ (synopsis "Rust library for doing URL percentage encoding")
(description
"This package provides a Rust library for doing URL percentage encoding.")
(license license:expat)))
diff --git a/gnu/packages/crates-web.scm b/gnu/packages/crates-web.scm
index c17402e335..f2fadfdeba 100644
--- a/gnu/packages/crates-web.scm
+++ b/gnu/packages/crates-web.scm
@@ -3724,7 +3724,7 @@ dependencies.")
("rust-hyper" ,rust-hyper-0.10)
("rust-native-tls" ,rust-native-tls-0.2))))
(home-page "https://github.com/sfackler/hyper-native-tls")
- (synopsis "native-tls support for Hyper 0.10")
+ (synopsis "Hyper 0.10 native-tls support")
(description "This package provides native-tls support for Hyper 0.10.")
(license (list license:expat license:asl2.0))))
@@ -5581,7 +5581,7 @@ alike. It's completely modular, and built directly for @code{async/await}.")
("rust-tokio" ,rust-tokio-1)
("rust-tower" ,rust-tower-0.4))))
(home-page "https://github.com/hyperium/tonic")
- (synopsis "gRPC over HTTP/2 implementation for Rust")
+ (synopsis "Rust implementation of gRPC over HTTP/2")
(description
"This package provides a @code{gRPC} over HTTP/2 implementation focused
on high performance, interoperability, and flexibility.")
@@ -6229,7 +6229,7 @@ the Trust-DNS client to use DNS over HTTPS.")
("rust-tokio-native-tls" ,rust-tokio-native-tls-0.3)
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20))))
(home-page "https://www.trust-dns.org/index.html")
- (synopsis "native-tls extension for the Trust-DNS client")
+ (synopsis "Trust-DNS client native-tls extension")
(description "Trust-DNS is a safe and secure DNS library. This is an
extension for the Trust-DNS client to use native-tls for TLS.")
(license (list license:expat license:asl2.0))))
@@ -6333,7 +6333,7 @@ extension for the Trust-DNS client to use native-tls for TLS.")
("rust-tokio-openssl" ,rust-tokio-openssl-0.6)
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20))))
(home-page "https://www.trust-dns.org/index.html")
- (synopsis "tokio-openssl extension for the Trust-DNS client")
+ (synopsis "Trust-DNS client tokio-openssl extension")
(description "Trust-DNS is a safe and secure DNS library. This is an
extension for the Trust-DNS client to use tokio-openssl for TLS.")
(license (list license:expat license:asl2.0))))
@@ -6958,7 +6958,7 @@ other queries.")
("rust-trust-dns-proto" ,rust-trust-dns-proto-0.20)
("rust-webpki" ,rust-webpki-0.21))))
(home-page "https://www.trust-dns.org/index.html")
- (synopsis "rustls extension for the Trust-DNS client")
+ (synopsis "Trust-DNS client rustls extension")
(description
"Trust-DNS is a safe and secure DNS library. This is an extension for
the Trust-DNS client to use rustls for TLS.")
@@ -7809,7 +7809,7 @@ GUIs as desktop applications.")
(native-inputs (list pkg-config))
(inputs (list curl openssl zlib))
(home-page "https://github.com/LukeMathWalker/wiremock-rs")
- (synopsis "HTTP mocking to test Rust applications.")
+ (synopsis "HTTP mocking to test Rust applications")
(description "This package provides HTTP mocking to test Rust
applications.")
(license (list license:expat license:asl2.0))))