aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerman Rimm <herman@rimm.ee>2024-02-18 22:03:05 +0100
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:42:30 +0300
commitb15631302227f989b9d3f8144b24fd6160697cb3 (patch)
tree6f99d2e929bfceca6241c0893d0b905f6c72fc1d
parenta37d360731aef7eaee60515c89a3da809bf89479 (diff)
downloadguix-b15631302227f989b9d3f8144b24fd6160697cb3.tar.gz
guix-b15631302227f989b9d3f8144b24fd6160697cb3.zip
gnu: Add rust-str-stack-0.1.
* gnu/packages/crates-io.scm (rust-str-stack-0.1): Add variable. Change-Id: I288ab5b984139a6bd2c9f3bc53a291a70239d908 Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 28dc97a750..11828f7129 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -68786,6 +68786,28 @@ UTF-8.")
(description "This package provides a static string buffer.")
(license license:boost1.0)))
+(define-public rust-str-stack-0.1
+ (package
+ (name "rust-str-stack")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "str_stack" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1sxl8xd8kiaffsryqpfwcb02lnd3djfin7gf38ag5980908vd4ch"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/Stebalien/str_stack")
+ (synopsis "String allocator for allocating many write-once strings")
+ (description
+ "This package provides a string allocator for allocating many write-once
+strings. This library is primarily useful for parsing where you need to
+repeatedly build many strings, use them, and then throw them away. Instead of
+allocating many independent strings, this library will put them all in the same
+buffer.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-stream-assert-0.1
(package
(name "rust-stream-assert")