aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelle Licht <jlicht@fsfe.org>2024-11-03 13:03:53 +0100
committerJelle Licht <jlicht@fsfe.org>2024-12-18 22:02:19 +0100
commitb0e5c1d038a201fd1233d182cdb9cc01ab5dd161 (patch)
tree0062de68e62aab03560ddab66f81b9150e4f6132
parent37ec990182034274b5614e48e24a9fa76f82ee13 (diff)
downloadguix-b0e5c1d038a201fd1233d182cdb9cc01ab5dd161.tar.gz
guix-b0e5c1d038a201fd1233d182cdb9cc01ab5dd161.zip
gnu: llhttp-bootstrap: Update to 8.1.2.
* gnu/packages/node.scm (llhttp-bootstrap): Update to 8.1.2. Change-Id: I4eff26889b2645c031fc9ea896657468d5752953
-rw-r--r--gnu/packages/node.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index 3997042e76..36ed22e052 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -680,7 +680,7 @@ parser definition into a C output.")
(define-public llhttp-bootstrap
(package
(name "llhttp")
- (version "6.0.11")
+ (version "8.1.2")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -689,7 +689,7 @@ parser definition into a C output.")
(file-name (git-file-name name version))
(sha256
(base32
- "16gaylka6nx9bsff9xga3s8xihxm3k7svrb88lr4dj2s4pzlfga9"))
+ "1808y8mpdcmsi8rxndilngg4nn2fbqfgb29f47kk9mmdpqg5s17r"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -715,6 +715,7 @@ parser definition into a C output.")
"/bin/esbuild")))
(invoke esbuild
"--platform=node"
+ "--target=node10"
"--outfile=bin/generate.js"
"--bundle" "bin/generate.ts"))))
(add-before 'install 'create-install-directories