aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 18:21:24 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-11-04 18:21:24 +0800
commitb0d5c6924c4e09aeb6a49a1aeb6139714b5f21cf (patch)
tree76f3e682c708f83b16fd324ace187d2b9c1faabe
parentfe6fdb1a85ef608f49ec54fb25db15b6d520ee6e (diff)
downloadguix-b0d5c6924c4e09aeb6a49a1aeb6139714b5f21cf.tar.gz
guix-b0d5c6924c4e09aeb6a49a1aeb6139714b5f21cf.zip
gnu: gifsicle: Build from git source.
* gnu/packages/image.scm (gifsicle)[source]: Switch to git-fetch. [native-inputs]: Add autoconf and automake. Change-Id: I9b23e1d2f66aa328f56bad224b8db03b6261dd00
-rw-r--r--gnu/packages/image.scm60
1 files changed, 34 insertions, 26 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 0d6593dc21..f20bb45915 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -2171,33 +2171,41 @@ stdout.")
(define-public gifsicle
(package
- (name "gifsicle")
- (version "1.95")
- (source
+ (name "gifsicle")
+ (version "1.95")
+ (source
(origin
- (method url-fetch)
- (uri (string-append "https://www.lcdf.org/gifsicle/gifsicle-"
- version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kohler/gifsicle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "0l69gn562l7a1l10zz1bfs756ipd682idgpk60qs3llz013icwdj"))))
- (build-system gnu-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-before 'check 'patch-tests
- (lambda _
- (substitute* "test/testie"
- (("/usr/bin/perl")
- (which "perl"))
- (("/bin/sh")
- (which "sh"))
- (("/bin/rm")
- (which "rm"))))))))
- (native-inputs (list perl)) ; only for tests
- (inputs (list libx11))
- (home-page "https://www.lcdf.org/gifsicle/")
- (synopsis "Edit GIF images and animations")
- (description "Gifsicle is a command-line GIF image manipulation tool that:
+ (base32 "1wvsf2kv90bqpyxcjilir4zgmaga0xjg96vnn7rzq4fkjx8pb3yg"))
+ (modules '((guix build utils)))
+ (snippet '(begin (substitute* "configure.ac"
+ (("2.72") "2.69"))))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda _
+ (substitute* "test/testie"
+ (("/usr/bin/perl")
+ (which "perl"))
+ (("/bin/sh")
+ (which "sh"))
+ (("/bin/rm")
+ (which "rm"))))))))
+ (native-inputs
+ (list
+ autoconf automake
+ perl)) ; only for tests
+ (inputs (list libx11))
+ (home-page "https://www.lcdf.org/gifsicle/")
+ (synopsis "Edit GIF images and animations")
+ (description "Gifsicle is a command-line GIF image manipulation tool that:
@itemize
@item Provides a batch mode for changing GIFs in place.
@@ -2212,7 +2220,7 @@ tables, etc.
Two other programs are included with Gifsicle: @command{gifview} is a
lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
identical visual appearance.")
- (license license:gpl2+)))
+ (license license:gpl2+)))
(define-public jp2a
(package