aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-10-10 02:29:33 -0400
committerArun Isaac <arunisaac@systemreboot.net>2021-10-16 15:39:52 +0530
commitb09daf52101dfacdbd545dd0545c8987d1ce1f97 (patch)
treeb6763d4af8356e55b1b8def1254abe2f981acd47
parent8730a8ab7ca73a2bc7e7f166ded04b0b1a8ddfaa (diff)
downloadguix-b09daf52101dfacdbd545dd0545c8987d1ce1f97.tar.gz
guix-b09daf52101dfacdbd545dd0545c8987d1ce1f97.zip
gnu: python-gitpython: Update to 3.1.24.
* gnu/packages/version-control.scm (python-gitpython): Update to 3.1.24. [arguments]: Do not return #t from custom phases. [propagated-inputs]: Add python-typing-extensions. Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
-rw-r--r--gnu/packages/version-control.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6d50f9e255..d7b1adadc7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -40,6 +40,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 François J. <francois-oss@avalenn.eu>
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1157,13 +1158,13 @@ allowing to handle large objects with a small memory footprint.")
(define-public python-gitpython
(package
(name "python-gitpython")
- (version "3.1.0")
+ (version "3.1.24")
(source (origin
(method url-fetch)
(uri (pypi-uri "GitPython" version))
(sha256
(base32
- "1jzllsy9lwc9yibccgv7h9naxisazx2n3zmpy21c8n5xhysw69p4"))))
+ "1rarp97cpjnhi106k2yhb7kygdyflmlgq0icxv3ggzl4wvszv0yz"))))
(build-system python-build-system)
(arguments
`(#:tests? #f ;XXX: Tests can only be run within the GitPython repository.
@@ -1174,12 +1175,12 @@ allowing to handle large objects with a small memory footprint.")
(("git_exec_name = \"git\"")
(string-append "git_exec_name = \""
(assoc-ref inputs "git")
- "/bin/git\"")))
- #t)))))
+ "/bin/git\""))))))))
(inputs
`(("git" ,git)))
(propagated-inputs
- `(("python-gitdb" ,python-gitdb)))
+ `(("python-gitdb" ,python-gitdb)
+ ("python-typing-extensions" ,python-typing-extensions)))
(native-inputs
`(("python-ddt" ,python-ddt)
("python-nose" ,python-nose)))
e): Add ‘xfs’ mapping. (create-xfs-file-system): New procedure. (format-user-partitions): Use it. * gnu/installer.scm (set-installer-path): Add xfsprogs. Tobias Geerinckx-Rice 2021-01-12installer: Fix crash in parameters menu....Fixes: <https://issues.guix.gnu.org/45378>. * gnu/installer/newt/keymap.scm (run-layout-page): Return false when "Continue" button is pressed. (run-keymap-page): Do not try to compute variants if layout is false. Also do not try to format the result if layout is false. * gnu/installer.scm (compute-keymap-step): Do not apply keymap if "run-keymap-page" returns false. Mathieu Othacehe 2020-12-11install: Discover local substitute servers....* gnu/installer/substitutes.scm: New file. * gnu/installer/newt/substitutes.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add them. * po/guix/POTFILES.in: Add gnu/installer/newt/substitutes.scm. * gnu/installer/proxy.scm (with-silent-shepherd): Move to ... * gnu/installer/utils.scm: ... here. * gnu/installer/record.scm (<installer>)[substitutes-page]: New field. * gnu/installer/newt.scm (substitutes-page): New procedure, (newt-installer): register it. * gnu/installer.scm (installer-steps): Add "substitutes-page" step. * gnu/system/install.scm (%installation-services): Add avahi-service-type and enable substitute server discover in guix-service-type. [<name-service-switch>]: Set it to %mdns-host-lookup-nss. Mathieu Othacehe e0ae2c77ac0241030748f7622acc264b'>gnu: ublock-origin: Update to 1.57.2....* gnu/packages/browser-extensions.scm (ublock-origin): Update to 1.57.2. (ublock-main-assets): Update to 1cfeef15ac031cf8ea144c7b8c7b6693fcd35664. (ublock-prod-assets): Update to 17d534c817bd543bbb5be48113edefcec43bbcc9. Change-Id: Ic955ada31e33f0cf0ab3ad272e6b7c2128d76aac Clément Lassieur