aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-30 23:00:47 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-10-31 10:43:56 +0800
commitaf7a5ea4e486301961fd32d545aad12e8fc4eb1c (patch)
treef598f5cc1b6542878192553acefb9b05ab97d356
parent39fc289fd66eb348062b05d9ab6acad817f386f6 (diff)
downloadguix-af7a5ea4e486301961fd32d545aad12e8fc4eb1c.tar.gz
guix-af7a5ea4e486301961fd32d545aad12e8fc4eb1c.zip
gnu: louvain-community: Don't tune native.
* gnu/packages/maths.scm (louvain-community)[arguments]<#:phases>: Add no-tune-native phase. [properties]: Add tunable? field. Change-Id: Idb1f54511f63bf62a9bf29cfb9177cd9f31b2390
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 4c526113f0..0966d66eac 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -66,6 +66,7 @@
;;; Copyright © 2024 Herman Rimm <herman@rimm.ee>
;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundation.xyz>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -9548,12 +9549,17 @@ true in all models.")
(add-after 'unpack 'encode-git-hash
(lambda _
(substitute* "CMakeLists.txt"
- (("GIT-hash-notfound") #$commit)))))))
+ (("GIT-hash-notfound") #$commit))))
+ (add-after 'unpack 'no-tune-native
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("-mtune=native") "")))))))
(native-inputs (list python))
(home-page "https://github.com/meelgroup/louvain-communities")
(synopsis "Multi-criteria community detection")
(description "This package provides a C++ implementation of the Louvain
community detection algorithm.")
+ (properties '((tunable? . #t)))
(license license:lgpl3+))))
(define-public cryptominisat