aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Scherer <roman@burningswell.com>2024-07-14 17:17:40 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2024-07-21 09:42:14 +0200
commitaeef827d2d494beeba6317a1e4720e4e285a7d4f (patch)
treeb3c8e6d23d7f3d10245961a25baa9bf004575a6c
parent3bd9ac84e49968ef9fa4496e61a56fe6cb52b30d (diff)
downloadguix-aeef827d2d494beeba6317a1e4720e4e285a7d4f.tar.gz
guix-aeef827d2d494beeba6317a1e4720e4e285a7d4f.zip
gnu: rapidcheck: Disable failing tests on aarch64.
* gnu/packages/check.scm (rapidcheck): Disable failing tests on aarch64. Change-Id: I9b4e7be2acad615cc1586adb37cc39b43590b2d8 Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/check.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 3bfcf5a37e..412b94569c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3500,7 +3500,13 @@ provides a simple way to achieve this.")
(display "find_package(Boost GLOBAL)\n" out)))
(substitute* "extras/boost/test/CMakeLists.txt"
(("^([ ]*)boost" all spaces)
- (string-append spaces "Boost::boost")))))))
+ (string-append spaces "Boost::boost")))
+ ;; Disable tests failing on Apple M1 and Hetzner CAX41 (aarch64).
+ ;; Upstream issue: https://github.com/emil-e/rapidcheck/issues/328
+ (substitute* "test/gen/NumericTests.cpp"
+ (("forEachType<SignedProperties.*") ""))
+ (substitute* "test/shrink/ShrinkTests.cpp"
+ (("forEachType<SignedIntegralProperties.*") ""))))))
(arguments
(list
#:configure-flags #~(list "-DCMAKE_POSITION_INDEPENDENT_CODE=ON"