aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 20:48:34 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:35 +0200
commitab021b964a3dcca07e241542a0f4de780d4cb99d (patch)
tree22364407de80f6be01f6cb3a9fe112ad24fe020a
parent26944757fbc8057c832380ed0c498b014d100bd2 (diff)
downloadguix-ab021b964a3dcca07e241542a0f4de780d4cb99d.tar.gz
guix-ab021b964a3dcca07e241542a0f4de780d4cb99d.zip
gnu: texlive-csquotes: Refresh package definition.
* gnu/packages/tex.scm (texlive-csquotes): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-ETOOLBOX, TEXLIVE-GRAPHICS, TEXLIVE-RELSIZE.
-rw-r--r--gnu/packages/tex.scm53
1 files changed, 29 insertions, 24 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2f11f2df9b..73942d3de9 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10742,30 +10742,35 @@ to what constitutes a good table in this context. The package offers
(license license:lppl1.3+)))
(define-public texlive-csquotes
- (let ((template (simple-texlive-package
- "texlive-csquotes"
- (list "/doc/latex/csquotes/"
- "/tex/latex/csquotes/")
- (base32
- "17y5mrmjmi7n0cgq4cnqr55f4bni6lx1pfdv5pzsmbrzha3mhbfg")
- #:trivial? #t)))
- (package
- (inherit template)
- (propagated-inputs
- (list texlive-etoolbox))
- (home-page "https://www.ctan.org/pkg/csquotes")
- (synopsis "Context sensitive quotation facilities")
- (description "This package provides advanced facilities for inline and
-display quotations. It is designed for a wide range of tasks ranging from the
-most simple applications to the more complex demands of formal quotations.
-The facilities include commands, environments, and user-definable 'smart
-quotes' which dynamically adjust to their context. Quotation marks are
-switched automatically if quotations are nested and they can be adjusted to
-the current language if the babel package is available. There are additional
-facilities designed to cope with the more specific demands of academic
-writing, especially in the humanities and the social sciences. All quote
-styles as well as the optional active quotes are freely configurable.")
- (license license:lppl1.3c+))))
+ (package
+ (name "texlive-csquotes")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/csquotes/"
+ "tex/latex/csquotes/")
+ (base32
+ "17y5mrmjmi7n0cgq4cnqr55f4bni6lx1pfdv5pzsmbrzha3mhbfg")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etoolbox
+ texlive-graphics
+ texlive-relsize))
+ (home-page "https://www.ctan.org/pkg/csquotes")
+ (synopsis "Context sensitive quotation facilities")
+ (description
+ "This package provides advanced facilities for inline and display
+quotations. It is designed for a wide range of tasks ranging from the most
+simple applications to the more complex demands of formal quotations. The
+facilities include commands, environments, and user-definable smart quotes
+which dynamically adjust to their context. Quotation marks are switched
+automatically if quotations are nested and they can be adjusted to the current
+language if the babel package is available. There are additional facilities
+designed to cope with the more specific demands of academic writing,
+especially in the humanities and the social sciences. All quote styles as
+well as the optional active quotes are freely configurable.")
+ (license license:lppl1.3c+)))
(define-public texlive-logreq
(package