aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 21:44:41 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-15 21:44:41 +0000
commitaadee4a58ddb4c0995c41dc4c0d16464665c54c1 (patch)
treec1331859e0d21709ea5fc93d0dfdef5b178056e1
parentf1d34da91261c71f91a02d6e47e1e21e8f368324 (diff)
downloadguix-aadee4a58ddb4c0995c41dc4c0d16464665c54c1.tar.gz
guix-aadee4a58ddb4c0995c41dc4c0d16464665c54c1.zip
gnu: go-ulid: Fix Texinfo markup in description.
Reported in #76312 by Leo Famulari <leo@famulari.name>. * gnu/packages/golang-xyz.scm (go-ulid): Swap to PACKAGE/INHERIT. [description]: Swap to go-github-com-oklog-ulid-v2; add leading "\n" to fix issue with Texinfo "@end itemize" line. [native-inputs]: Remove go-github-pborman-getopt-v2. Change-Id: I5bc34db4c4d244e9f11f2cb4875344d48bd14ec9
-rw-r--r--gnu/packages/golang-xyz.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a74d82dbb8..947167ca9a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -18070,19 +18070,16 @@ tools."))))
tool."))))
(define-public go-ulid
- (package
- (inherit go-github-com-oklog-ulid-v2)
+ (package/inherit go-github-com-oklog-ulid-v2
(name "go-ulid")
(arguments
(list
#:install-source? #f
#:import-path "github.com/oklog/ulid/v2/cmd/ulid"
#:unpack-path "github.com/oklog/ulid/v2"))
- (native-inputs
- (list go-github-com-pborman-getopt-v2))
(description
- (string-append (package-description go-github-com-oklog-ulid)
- " This package provides an command line interface (CLI)
+ (string-append (package-description go-github-com-oklog-ulid-v2)
+ "\nThis package provides a command line interface (CLI)
tool."))))
(define-public gofumpt