aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-12-10 10:07:51 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:48 +0200
commita9136076eb639731581cb50e996f63e431eaff72 (patch)
tree9e5c394d8f00e75a550b5b05afd39e4b12541293
parent0c9811497e9ed980cdcf93ffc9c112947aef694b (diff)
downloadguix-a9136076eb639731581cb50e996f63e431eaff72.tar.gz
guix-a9136076eb639731581cb50e996f63e431eaff72.zip
gnu: clang-from-llvm: Use gcc's search paths.
* gnu/packages/llvm.scm (clang-from-llvm)[native-search-paths]: Use %gcc-search-paths. Change-Id: I777cab55e8a1931502a537c0680608d7d6b5b715
-rw-r--r--gnu/packages/llvm.scm15
1 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 0c0ec1bca1..f27ab5e3b4 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -50,6 +50,7 @@
#:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix memoization)
+ #:use-module (guix search-paths)
#:use-module (guix utils)
#:use-module (guix build-system cmake)
#:use-module (guix build-system emacs)
@@ -464,19 +465,7 @@ ttest third-party/unittest)\n" line))))))
#t)))))
;; Clang supports the same environment variables as GCC.
- (native-search-paths
- (list (search-path-specification
- (variable "C_INCLUDE_PATH")
- (files '("include")))
- (search-path-specification
- (variable "CPLUS_INCLUDE_PATH")
- (files '("include/c++" "include")))
- (search-path-specification
- (variable "OBJC_INCLUDE_PATH")
- (files '("include")))
- (search-path-specification
- (variable "LIBRARY_PATH")
- (files '("lib" "lib64")))))
+ (native-search-paths %gcc-search-paths)
(home-page "https://clang.llvm.org")
(synopsis "C language family frontend for LLVM")