aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-18 12:11:37 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:38 +0200
commita8faac6725e3b5ebde364587213b4906c8f23fc3 (patch)
tree5d06b4175a4fb3cbe935b9a0e51a8a6fe521129f
parent83ca20dd7cf5381f19d4d331d2675b4ffac988ca (diff)
downloadguix-a8faac6725e3b5ebde364587213b4906c8f23fc3.tar.gz
guix-a8faac6725e3b5ebde364587213b4906c8f23fc3.zip
gnu: Add texlive-figbib.
* gnu/packages/tex.scm (texlive-figbib): New variable.
-rw-r--r--gnu/packages/tex.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4c559eb05b..c085f46ce5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -8719,6 +8719,38 @@ music manuscripts. The fonts are usable with Computer Modern Roman and Sans,
and Palatino/Palladio, respectively.")
(license license:lppl)))
+(define-public texlive-figbib
+ (package
+ (name "texlive-figbib")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "bibtex/bst/figbib/" "doc/latex/figbib/"
+ "tex/latex/figbib/")
+ (base32
+ "1wvglj3z86xjz1bi5931hxm9b2kn6r4j7391di26wmsyhdajs2yz")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/figbib")
+ (synopsis "Organize figure databases with BibTeX")
+ (description
+ "FigBib lets you organize your figures in BibTeX databases. Some FigBib
+features are:
+@itemize
+
+@item store and manage figures in a BibTeX database;
+
+@item Include figures in your LaTeX document with one short command;
+
+@item generate a list of figures containing more or other information than the
+figure captions;
+
+@item control with one switch where to output the figures, either as usual
+float objects or in a separate part at the end of your document.
+
+@end itemize")
+ (license license:lppl)))
+
(define-public texlive-filecontentsdef
(package
(name "texlive-filecontentsdef")