aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:47:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:54 +0200
commita8de5e3a2a3830bb2a979d2697a4d940b0b3b015 (patch)
tree23cd093d26d7b1f45daba7044f18f629fa72841b
parentf35acb911be34e54564a2ca17a173bf832afb1a7 (diff)
downloadguix-a8de5e3a2a3830bb2a979d2697a4d940b0b3b015.tar.gz
guix-a8de5e3a2a3830bb2a979d2697a4d940b0b3b015.zip
gnu: texlive-intcalc: Refresh package definition.
* gnu/packages/tex.scm (texlive-intcalc): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 16 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74dafc6bea..1991500582 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9642,28 +9642,23 @@ implementations.")
(define-deprecated-package texlive-generic-infwarerr texlive-infwarerr)
(define-public texlive-intcalc
- (let ((template (simple-texlive-package
- "texlive-intcalc"
- (list "doc/latex/intcalc/"
- "source/latex/intcalc/"
- "tex/generic/intcalc/")
- (base32
- "15alwp9cr8wasfajs3p201p7nqml37vly9mpg1j5l6xv95javk7x"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "generic/intcalc")
- ((#:build-targets _ '())
- #~(list "intcalc.dtx"))))
- (home-page "https://www.ctan.org/pkg/intcalc")
- (synopsis "Expandable arithmetic operations with integers")
- (description
- "This package provides expandable arithmetic operations with integers,
+ (package
+ (name "texlive-intcalc")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/intcalc/" "source/latex/intcalc/"
+ "tex/generic/intcalc/")
+ (base32
+ "15alwp9cr8wasfajs3p201p7nqml37vly9mpg1j5l6xv95javk7x")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/intcalc")
+ (synopsis "Expandable arithmetic operations with integers")
+ (description
+ "This package provides expandable arithmetic operations with integers,
using the e-TeX extension @code{\\numexpr} if it is available.")
- (license license:lppl1.3c+))))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-generic-intcalc texlive-intcalc)