aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-13 09:04:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:17:24 +0200
commita8a9039f6ea62900c973e0298cedef9322e0a307 (patch)
tree59733059cda5ca5aed94ccee3e61e42e27cc1b09
parent1b82fc636da96bc1918e698e442b818e26a2a9cd (diff)
downloadguix-a8a9039f6ea62900c973e0298cedef9322e0a307.tar.gz
guix-a8a9039f6ea62900c973e0298cedef9322e0a307.zip
gnu: Add texlive-maker.
* gnu/packages/tex.scm (texlive-maker): New variable.
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1a6fe5ae8c..9e34dc388f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2567,6 +2567,27 @@ with LuaLaTeX. This version uses less memory, and operates faster than the
original; it also offers several enhancements.")
(license license:lppl1.3+)))
+(define-public texlive-maker
+ (package
+ (name "texlive-maker")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/maker/" "tex/latex/maker/")
+ (base32
+ "08shs5fah2yfdgsydk93jfb1sz42qckal2p031vs95vqd8rpq11g")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/maker")
+ (synopsis "Include Arduino or Processing code in LaTeX documents")
+ (description
+ "The first version of the package allows to include Arduino or Processing
+code using three different forms: writing the code directly in the LaTeX
+document, writing Arduino or Processing commands in line with the text,
+calling to Arduino or Processing files. All these options support the syntax
+highlighting of the official IDE.")
+ (license license:lppl1.3c)))
+
(define-public texlive-mflogo
(package
(name "texlive-mflogo")