aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-18 11:33:11 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-18 20:54:04 -0500
commita7afeaefc582882bf84b55b450f18d336e1c010c (patch)
tree6670331c0d69d69ae66b6abd76907d30a4121b0a
parent51ffddf04b60a218b79ed2597c0368303be2e7a3 (diff)
downloadguix-a7afeaefc582882bf84b55b450f18d336e1c010c.tar.gz
guix-a7afeaefc582882bf84b55b450f18d336e1c010c.zip
gnu: kholidays: Update to 5.114.0.
* gnu/packages/kde-frameworks.scm (kholidays): Update to 5.114.0. Change-Id: I37d6006cdefa134364a60a85859505c2d451b138
-rw-r--r--gnu/packages/kde-frameworks.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d3ac4e77fb..8cf27981dc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -823,7 +823,7 @@ interfaces in the areas of colors, fonts, text, images, keyboard input.")
(define-public kholidays
(package
(name "kholidays")
- (version "5.108.0")
+ (version "5.114.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -831,7 +831,7 @@ interfaces in the areas of colors, fonts, text, images, keyboard input.")
(version-major+minor version) "/"
name "-" version ".tar.xz"))
(sha256
- (base32 "03g484nm37vv8mnj4q6y6pdrhhiglni3s63gpxhc54zzhzxshpy5"))))
+ (base32 "19r8dxglz5ll6iyvigsccil3ikvcsnyy5nwcpjvjr1c0brigcjmy"))))
(build-system cmake-build-system)
(native-inputs
(list extra-cmake-modules qttools-5))
ingly. * tests/store.scm ("map/accumulate-builds and different store"): New test. Ludovic Courtès 2021-09-17Merge branch 'master' into core-updates-frozen... Conflicts: gnu/packages/bioinformatics.scm gnu/packages/chez.scm gnu/packages/docbook.scm gnu/packages/ebook.scm gnu/packages/gnome.scm gnu/packages/linux.scm gnu/packages/networking.scm gnu/packages/python-web.scm gnu/packages/python-xyz.scm gnu/packages/tex.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/dune.scm guix/build-system/go.scm guix/build-system/linux-module.scm guix/packages.scm Marius Bakke 2021-09-15store: 'map/accumulate-builds' processes the whole list in case of cutoff....Fixes <https://issues.guix.gnu.org/50264>. Reported by Lars-Dominik Braun <lars@6xq.net>. This fixes a regression introduced in fa81971cbae85b39183ccf8f51e8d96ac88fb4ac whereby 'map/accumulate-builds' would return REST (the tail of LST) without applying PROC on it. The effect would be that 'lower-inputs' in (guix gexp) would dismiss those elements, leading to derivations with correct builders but only a subset of the inputs they should have had. * guix/store.scm (map/accumulate-builds): Add #:cutoff parameter and remove 'accumulation-cutoff' variable. Call PROC on the elements of REST. * tests/store.scm ("map/accumulate-builds cutoff"): New test. Ludovic Courtès 2021-07-05tests: Fix typo in 'tests/store.scm'....This typo had always been there since the test was introduced in commit ce72c780746776a86f59747f5eff8731cb4ff39b. Presumably, it became visible with 9e5812ac59b01ff011ec0c5b0f437dfe85d6fcc7, where caching was no longer global and thus the 'store' argument of 'package-derivation' was actually being used. * tests/store.scm ("current-build-output-port, UTF-8"): Refer to '%store' rather than 's' in 'package-derivation' call. Ludovic Courtès 2021-06-08store: Remove 'references/substitutes'....This procedure lost its only user in commit 710854304b1ab29332edcb76f3de532e0724c197. * guix/store.scm (references/substitutes): Remove. * tests/store.scm ("references/substitutes missing reference info") ("references/substitutes with substitute info"): Remove. Ludovic Courtès 2021-03-18tests: Make the STORE test more robust in a "pure" environment....Otherwise, the test crashes (not fails) when run in `guix environment --pure guix`. Fixes <https://bugs.gnu.org/46445>. * tests/store.scm (%shell): Fallback to "/bin/sh". Leo Famulari 2021-01-22store: Add 'find-roots' RPC....* guix/serialization.scm (read-string-pairs): New procedure. * guix/store.scm (read-arg): Add support for 'string-pairs'. (find-roots): New procedure. * tests/store.scm ("add-indirect-root and find-roots"): New test. Ludovic Courtès 2020-12-19tests: Make sure substituted items are deduplicated....* tests/store.scm ("substitute, deduplication"): New test. Ludovic Courtès 2020-12-19tests: Check the mtime and permissions of substituted items....* tests/store.scm ("substitute") ("substitute + build-things with output path") ("substitute + build-things with specific output"): Call 'canonical-file?'. * tests/substitute.scm ("substitute, authorized key"): Check the mtime and permissions of "substitute-retrieved". Ludovic Courtès 2020-12-19tests: Check the build trace for hash mismatches on substitutes....* tests/store.scm ("substitute, corrupt output hash, build trace"): New test. Ludovic Courtès