aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-12-15 15:41:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2025-01-06 12:15:03 +0200
commita7af54ec322297cd171000fbe9df6fe70f59a482 (patch)
tree5c9aedbab0bdf716afa5bc91f3679baca4f726d2
parentcba48b514bada0f3f6ecf234174566a1a453ce3b (diff)
downloadguix-a7af54ec322297cd171000fbe9df6fe70f59a482.tar.gz
guix-a7af54ec322297cd171000fbe9df6fe70f59a482.zip
gnu: Add rust-pyo3-0.23.
* gnu/packages/crates-io.scm (rust-pyo3-0.23): New variable. (rust-pyo3-0.22): Inherit from rust-pyo3-0.23. Change-Id: I026d42ad383641e8c26b7aa51a53eda739957526
-rw-r--r--gnu/packages/crates-io.scm72
1 files changed, 62 insertions, 10 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9f595acf41..985b400c74 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -63217,8 +63217,69 @@ extension to python.")
("rust-syn" ,rust-syn-1))))
(native-inputs (list python))))
+(define-public rust-pyo3-0.23
+ (package
+ (name "rust-pyo3")
+ (version "0.23.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pyo3" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "05bclbdhj210gpq0i7w16369y6cgzbb1z3ribaq7mdjcicngv174"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
+ ("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.10)
+ ("rust-either" ,rust-either-1)
+ ("rust-eyre" ,rust-eyre-0.6)
+ ("rust-hashbrown" ,rust-hashbrown-0.15)
+ ("rust-indexmap" ,rust-indexmap-2)
+ ("rust-indoc" ,rust-indoc-2)
+ ("rust-inventory" ,rust-inventory-0.3)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-memoffset" ,rust-memoffset-0.9)
+ ("rust-num-bigint" ,rust-num-bigint-0.4)
+ ("rust-num-complex" ,rust-num-complex-0.4)
+ ("rust-num-rational" ,rust-num-rational-0.4)
+ ("rust-once-cell" ,rust-once-cell-1)
+ ("rust-portable-atomic" ,rust-portable-atomic-1)
+ ("rust-pyo3-build-config" ,rust-pyo3-build-config-0.23)
+ ("rust-pyo3-ffi" ,rust-pyo3-ffi-0.23)
+ ("rust-pyo3-macros" ,rust-pyo3-macros-0.23)
+ ("rust-rust-decimal" ,rust-rust-decimal-1)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-smallvec" ,rust-smallvec-1)
+ ("rust-unindent" ,rust-unindent-0.2))
+ #:cargo-development-inputs
+ (("rust-assert-approx-eq" ,rust-assert-approx-eq-1)
+ ("rust-chrono" ,rust-chrono-0.4)
+ ("rust-chrono-tz" ,rust-chrono-tz-0.10)
+ ("rust-futures" ,rust-futures-0.3)
+ ("rust-proptest" ,rust-proptest-1)
+ ("rust-rayon" ,rust-rayon-1)
+ ("rust-send-wrapper" ,rust-send-wrapper-0.6)
+ ("rust-serde" ,rust-serde-1)
+ ("rust-serde-json" ,rust-serde-json-1)
+ ("rust-static-assertions" ,rust-static-assertions-1)
+ ("rust-tempfile" ,rust-tempfile-3)
+ ("rust-trybuild" ,rust-trybuild-1)
+ ("rust-uuid" ,rust-uuid-1))))
+ (inputs (list python-minimal))
+ (home-page "https://github.com/pyo3/pyo3")
+ (synopsis "Rust bindings for the Python interpreter")
+ (description
+ "This package provides Rust bindings for Python, including tools for
+creating native Python extension modules. Running and interacting with
+Python code from a Rust binary is also supported.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-pyo3-0.22
(package
+ (inherit rust-pyo3-0.23)
(name "rust-pyo3")
(version "0.22.6")
(source
@@ -63228,7 +63289,6 @@ extension to python.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "110qrq9yibfv40zzind9p2i87617lhzs379ix0m2065b2qk0c0pl"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs (("rust-anyhow" ,rust-anyhow-1)
("rust-cfg-if" ,rust-cfg-if-1)
@@ -63265,15 +63325,7 @@ extension to python.")
("rust-serde" ,rust-serde-1)
("rust-serde-json" ,rust-serde-json-1)
("rust-static-assertions" ,rust-static-assertions-1)
- ("rust-trybuild" ,rust-trybuild-1))))
- (inputs (list python-minimal))
- (home-page "https://github.com/pyo3/pyo3")
- (synopsis "Rust bindings for the Python interpreter")
- (description
- "This package provides Rust bindings for Python, including tools for
-creating native Python extension modules. Running and interacting with
-Python code from a Rust binary is also supported.")
- (license (list license:expat license:asl2.0))))
+ ("rust-trybuild" ,rust-trybuild-1))))))
(define-public rust-pyo3-0.21
(package