aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-17 23:01:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:24 +0100
commita6ab0705c4a05d3b27b50258e8a0cb7c8fcdca16 (patch)
tree7d041f459f7f9ac8614e05d6d2a82c0902557bf0
parent6be739763cd66ac7fe5190f11f5d2a34d019c0b7 (diff)
downloadguix-a6ab0705c4a05d3b27b50258e8a0cb7c8fcdca16.tar.gz
guix-a6ab0705c4a05d3b27b50258e8a0cb7c8fcdca16.zip
gnu: python-gast: Update to 0.6.0.
* gnu/packages/python-xyz.scm (python-gast): Update to 0.6.0. [build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. [native-inputs]: Add python-setuptools and python-wheel. [propagated-inputs]: Remove. Change-Id: I3cc17b2c5434e637435f76482e0dcaf54c75c0dd
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 4 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cfccf0c63f..8ce85e8a25 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30287,24 +30287,16 @@ distribution.")
(define-public python-gast
(package
(name "python-gast")
- (version "0.5.3")
+ (version "0.6.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "gast" version))
(sha256
- (base32 "1sidaczriw54pfkj3523y9j9q2harrczc1qqgnfaylz641ca5gng"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (base32 "1yxinr3xvxf0cryfrfr9q3rgvrki5y310lsigg5ccyicsc057z48"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-pytest))
- (propagated-inputs
- (list python-astunparse))
+ (list python-pytest python-setuptools python-wheel))
(home-page "https://github.com/serge-sans-paille/gast/")
(synopsis "Generic Python AST that abstracts the underlying Python version")
(description