aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2020-09-19 21:38:36 +0530
committerArun Isaac <arunisaac@systemreboot.net>2020-10-12 11:41:57 +0530
commita5d74972043863fe0afd0b2908f9b85ac6180eaf (patch)
tree2ed13cc30124a0f6ce28fe702e10c10dfefa1bf6
parentc91fff483d0772af1c169c8837d202eeba75431d (diff)
downloadguix-a5d74972043863fe0afd0b2908f9b85ac6180eaf.tar.gz
guix-a5d74972043863fe0afd0b2908f9b85ac6180eaf.zip
gnu: Add rust-bindgen-0.55.
* gnu/packages/crates-io.scm (rust-bindgen-0.55): New variable. (rust-bindgen-0.54): Inherit from rust-bindgen-0.55.
-rw-r--r--gnu/packages/crates-io.scm63
1 files changed, 56 insertions, 7 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4c7aaac542..3aa54cddba 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1583,8 +1583,63 @@ tracebacks.")
that uses Serde for transforming structs into bytes and vice versa!")
(license license:expat)))
+(define-public rust-bindgen-0.55
+ (package
+ (name "rust-bindgen")
+ (version "0.55.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "bindgen" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hxlvy9q9984rr3rqaxwmgxjrd9wh11mcc161hv3shz6b7jkrcbm"))))
+ (build-system cargo-build-system)
+ (inputs
+ `(("clang" ,clang)))
+ (arguments
+ `(#:cargo-inputs
+ (("rust-bitflags" ,rust-bitflags-1)
+ ("rust-cexpr" ,rust-cexpr-0.4)
+ ("rust-cfg-if" ,rust-cfg-if-0.1)
+ ("rust-clang-sys" ,rust-clang-sys-1)
+ ("rust-clap" ,rust-clap-2)
+ ("rust-env-logger" ,rust-env-logger-0.7)
+ ("rust-lazy-static" ,rust-lazy-static-1)
+ ("rust-lazycell" ,rust-lazycell-1)
+ ("rust-log" ,rust-log-0.4)
+ ("rust-peeking-take-while" ,rust-peeking-take-while-0.1)
+ ("rust-proc-macro2" ,rust-proc-macro2-1)
+ ("rust-quote" ,rust-quote-1)
+ ("rust-regex" ,rust-regex-1)
+ ("rust-rustc-hash" ,rust-rustc-hash-1)
+ ("rust-shlex" ,rust-shlex-0.1)
+ ("rust-which" ,rust-which-3))
+ #:cargo-development-inputs
+ (("rust-clap" ,rust-clap-2)
+ ("rust-diff" ,rust-diff-0.1)
+ ("rust-shlex" ,rust-shlex-0.1))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enable-unstable-features
+ (lambda _
+ (setenv "RUSTC_BOOTSTRAP" "1")
+ #t))
+ (add-before 'configure 'configure-clang
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "LIBCLANG_PATH" (string-append (assoc-ref inputs "clang")
+ "/lib"))
+ #t)))))
+ (home-page "https://rust-lang.github.io/rust-bindgen/")
+ (synopsis "Generate Rust FFI bindings to C and C++ libraries.")
+ (description "This package can be used to automatically generate Rust FFI
+bindings to C and C++ libraries.")
+ (license license:bsd-3)))
+
(define-public rust-bindgen-0.54
(package
+ (inherit rust-bindgen-0.55)
(name "rust-bindgen")
(version "0.54.1")
(source
@@ -1629,13 +1684,7 @@ that uses Serde for transforming structs into bytes and vice versa!")
(string-append clang "/lib")))
#t)))))
(inputs
- `(("libclang" ,clang)))
- (home-page "https://rust-lang.github.io/rust-bindgen/")
- (synopsis
- "Automatically generates Rust FFI bindings to C and C++ libraries")
- (description
- "Automatically generates Rust FFI bindings to C and C++ libraries.")
- (license license:bsd-3)))
+ `(("libclang" ,clang)))))
(define-public rust-bindgen-0.53
(package