aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-12 16:12:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-12 17:44:46 +0200
commita589acfb08882cf7978d53a21d0ed27926b44a4e (patch)
tree342f747593744e9814a1f72b64ee3852c3a56456
parent348bb8d6631f3c288777c3a9fb26061dd26de91d (diff)
downloadguix-a589acfb08882cf7978d53a21d0ed27926b44a4e.tar.gz
guix-a589acfb08882cf7978d53a21d0ed27926b44a4e.zip
gnu: Add r-tibble.
* gnu/packages/statistics.scm (r-tibble): New variable.
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index d658c8f44f..d6b57b7fa7 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -1078,6 +1078,29 @@ private members, and they support inheritance, even when the classes are
defined in different packages.")
(license license:expat)))
+(define-public r-tibble
+ (package
+ (name "r-tibble")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "tibble" version))
+ (sha256
+ (base32
+ "011i352ylq9b4xfcj7h10h7qsqd9qkc1rzc0pr1gf8qjb788p2pd"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-assertthat" ,r-assertthat)
+ ("r-lazyeval" ,r-lazyeval)
+ ("r-rcpp" ,r-rcpp)))
+ (home-page "https://github.com/hadley/tibble")
+ (synopsis "Simple data frames")
+ (description
+ "This package provides a @code{tbl_df} class that offers better checking
+and printing capabilities than traditional data frames.")
+ (license license:expat)))
+
(define-public r-dplyr
(package
(name "r-dplyr")
d colspan='3' class='logmsg'> * po/doc/local.mk (doc-pot-update): Fix an issue where guix.pot-update an contributing.pot-update were built twice. 2021-04-18nls: Fix Chinese cookbook inclusion.Julien Lepiller * po/doc/local.mk: zh_Hans is for the cookbook, not the manual. 2021-04-18nls: Update 'ru' translation.Julien Lepiller 2021-04-18nls: Add Chinese (Traditional) translation.Julien Lepiller * po/doc/guix-cookbook.zh_Hans.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add it. 2021-04-18nls: Add Korean translation.Julien Lepiller * po/doc/guix-cookbook.ko.po: New file. * po/doc/guix-manual.ko.po: New file. * doc/local.mk (info_TEXINFOS): Add them. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * po/guix/ko.po: New file. * po/guix/LINGUAS: Add 'ko'. * po/packages/ko.po: New file. * po/packages/LINGUAS: Add 'ko'. 2021-04-18nls: Add Italian translation.Julien Lepiller * po/doc/guix-manual.it.po: New file. * po/doc/local.mk (DOC_PO_FILES): Add it. * doc/local.mk (info_TEXINFOS): Add it. * po/guix/it.po: New file. * po/guix/LINGUAS: Add 'it'. 2021-04-18nls: Add Persian translation.Julien Lepiller * po/packages/fa.po: New file. * po/packages/LINGUAS: Add 'fa'. * po/doc/guix-cookbook.fa.po: New file. * po/doc/guix-manual.fa.po: New file. * po/doc/local.mk (DOC_PO_FILES, DOC_COOKBOOK_PO_FILES): Add them. * doc/local.mk (info_TEXINFOS): Add them. 2021-04-18nls: Add Slovak translation.Julien Lepiller * po/packages/sk.po: New file. * po/packages/LINGUAS: Add 'sk'. * po/doc/guix-manual.sk.po: New file. * doc/local.mk (info_TEXINFOS): Add it. * po/doc/local.mk (DOC_PO_FILES): Add it. 2021-04-18nls: Add Portuguese (Brazil) translation of the manual.Julien Lepiller 2021-04-18nls: Update 'zh_CN' translations.Julien Lepiller 2021-04-18nls: Update 'es' translations.Julien Lepiller 2021-04-18nls: Update 'de' translations.Julien Lepiller 2021-04-18nls: Update 'fr' translations.Julien Lepiller 2021-04-18nls: Add French translation of the cookbook.Julien Lepiller 2021-01-28nls: Update 'fr' translation.Julien Lepiller 2021-01-22Revert "nls: Update 'fr' translation."Ludovic Courtès This reverts commit 5d03ef73c3c1d995714abdaff650f73ac9fafc0f, which led to these errors: /gnu/store/…-guix/fr.po:7206: 'msgstr' is not a valid Scheme format string, unlike 'msgid'. Reason: In the directive number 3, the character ' ' is not a valid conversion specifier. /gnu/store/…-guix/fr.po:7554: format specifications in 'msgid' and 'msgstr' are not equivalent /gnu/store/…-gettext-minimal-0.20.1/bin/msgfmt: found 2 fatal errors 2021-01-22nls: Update 'fr' translation.Julien Lepiller 2020-12-03nls: Update 'fr' translation of the manual.Ludovic Courtès 2020-11-21nls: Update 'fr' translation of the manual.Ludovic Courtès 2020-11-12nls: Update translations of the manual.Ludovic Courtès 2020-11-12nls: Update translations of the manual.Julien Lepiller 2020-11-03nls: Fix Texinfo typo.Tobias Geerinckx-Rice * po/doc/guix-manual.de.po: Fix ‘@sasmp{}’ that broke ‘make’. 2020-11-03nls: Update translations of the manual.Julien Lepiller 2020-11-01nls: Update ‘de’ cookbook translation.Florian Pelz 2020-10-30nls: Update 'fr' translation of the manual.Julien Lepiller 2020-10-29nls: Update 'ru' translation of the manual.Julien Lepiller 2020-10-27nls: Update.Ludovic Courtès 2020-10-16nls: Update manual translations.Ludovic Courtès 2020-09-29nls: Fix documentation pot generation.Julien Lepiller * po/doc/local.mk: Fix POT_OPTIONS to properly assign copyright and define the proper license. 2020-05-05nls: Update.Ludovic Courtès 2020-04-12nls: Update.Ludovic Courtès 2020-03-23nls: Update.Ludovic Courtès 2020-03-06doc: Fix build of German Cookbook translation.Florian Pelz This is a follow-up to f98e83a17fa30587520e858231ec9c61f3624ecd. See <https://lists.gnu.org/archive/html/guix-devel/2020-03/msg00095.html>. Reported there by Vagrant Cascadian <vagrant@debian.org>. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Use correct file name. (doc-po-update-cookbook-%): Use correct PO file name. 2020-02-17doc: Add German Cookbook translation.Florian Pelz * doc/local.mk (info_TEXINFOS): Add guix-cookbook.de.texi. (TRANSLATED_INFO): Add guix-cookbook.de.texi. * po/doc/guix-cookbook.de.po: New file. * po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add guix-cookbook.de.po. 2020-02-14Revert "nls: Update 'es' translation of the manual."Christopher Baines I believe this change breaks guix pull: ./guix.es.texi:20971: @samp missing closing brace This reverts commit d156e3fbcd6fc61a39d1d32622b90b0f8f741729. 2020-02-14nls: Update 'de' translation of the manual.Julien Lepiller 2020-02-14nls: Update 'es' translation of the manual.Julien Lepiller