aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-08-31 00:59:31 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-03 13:59:34 +0200
commita56affbdd8b44aa68f504563d8a552398a3ca937 (patch)
tree559a0ee50fbd0a5f6a2a685895f4b33a6d1e97cc
parent1b2f42f26b2688482f82948f7c6a5a804c2f3b61 (diff)
downloadguix-a56affbdd8b44aa68f504563d8a552398a3ca937.tar.gz
guix-a56affbdd8b44aa68f504563d8a552398a3ca937.zip
gnu: Add julia-progressbars.
* gnu/packages/julia-xyz.scm (julia-progressbars): New variable. Change-Id: Idd2b6a8aaaec186c01ecbc852d03f3df84bab8b5 Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 56a3c9772d..1743d27226 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4917,6 +4918,27 @@ everything from run time algorithm choice to code generation at compile time.")
human-readable format.")
(license license:expat)))
+(define-public julia-progressbars
+ (package
+ (name "julia-progressbars")
+ (version "1.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/cloud-oak/ProgressBars.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y4i2kdir0wxr3amafidr3585w8lj4s0cqfcbl690a8jvw6rs3jw"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/cloud-oak/ProgressBars.jl")
+ (synopsis "Progress bar for Julia")
+ (description
+ "This package provides a fast, extensible progress bar for Julia.
+This can help users track the progress of long-running tasks.")
+ (license license:mpl2.0)))
+
(define-public julia-pycall
(package
(name "julia-pycall")