aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-12-16 08:37:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2025-01-20 21:37:20 +0100
commita265018b7b74871738b0a1cc173d518c9e7944a8 (patch)
tree86991db55edbf0838bfc10fadc8e05d6820d39b0
parent1d09655c754a420672b9cf8f98ca086ae193d2b0 (diff)
downloadguix-a265018b7b74871738b0a1cc173d518c9e7944a8.tar.gz
guix-a265018b7b74871738b0a1cc173d518c9e7944a8.zip
gnu: python-pyramid: Update to 2.0.2.
* gnu/packages/python-web.scm (python-pyramid): Update to 2.0.2. [build-system]: Use pyproject-build-system. [propagated-inputs]: Add python-setuptools; move python-webtest from here... [native-inputs]: ...to here; add python-pytest and python-wheel. Change-Id: I9f397c4d3c8fef2b10f591cbca504f6cc14cd715
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 4e2738cb63..78a5fbf834 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -7410,25 +7410,26 @@ changed the process is restarted.")
(define-public python-pyramid
(package
(name "python-pyramid")
- (version "1.10.4")
+ (version "2.0.2")
(source (origin
(method url-fetch)
(uri (pypi-uri "pyramid" version))
(sha256
(base32
- "0rkxs1ajycg2zh1c94xlmls56mx5m161sn8112skj0amza6cn36q"))))
- (build-system python-build-system)
+ "1phqdz068hl3zda263qkjp5am8fmvmpcxp3nrhsna8g472kkh89p"))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-hupper
+ python-plaster
python-plaster-pastedeploy
+ python-setuptools
python-translationstring
python-venusian
python-webob
- python-zope-deprecation
- python-zope-interface
- python-webtest
python-zope-component
- python-plaster))
+ python-zope-deprecation
+ python-zope-interface))
+ (native-inputs (list python-pytest python-webtest python-wheel))
(home-page "https://trypyramid.com/")
(synopsis "Python web-framework suitable for small and large sites")
(description