aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-14 22:11:15 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-09-14 23:18:24 +0900
commita08fc6e60a84232648f7c043218be33f2d1949b0 (patch)
tree1c875a64cbe44214eea767cc4e854b11b67fc55e
parentff7bba8baa293865b92316824e1ae1c3b04db97c (diff)
downloadguix-a08fc6e60a84232648f7c043218be33f2d1949b0.tar.gz
guix-a08fc6e60a84232648f7c043218be33f2d1949b0.zip
gnu: linux-libre: Properly enable CONFIG_BPF_UNPRIV_DEFAULT_OFF.
* gnu/packages/linux.scm (default-extra-linux-options): Fixes: https://issues.guix.gnu.org/72794 Reported-by: Jorge Acereda <jacereda@gmail.com> Change-Id: Ie4db277e6e3e54ed835ffbeabd2119688bf63dbb
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f3bcfd9f84..5c40e5e33f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -851,7 +851,7 @@ ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_BPF_SYSCALL" . #t))
'())
,@(if (version>=? version "5.13")
- '(("BPF_UNPRIV_DEFAULT_OFF" . #t))
+ '(("CONFIG_BPF_UNPRIV_DEFAULT_OFF" . #t))
'())
("CONFIG_NET_CLS_BPF" . m) ;classify packets based on BPF filters
("CONFIG_NET_ACT_BPF" . m) ;to execute BPF code on packets